Read the docs
TI-2025-31052 Aliases CVE-2025-48912GHSA-8w7f-8pr9-xgwj

Apache Superset: Improper authorization bypass on row level security via SQL Injection

Priority LOW 33CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00786 56th percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 4.1.2apache-superset (PyPI): 4.1.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetbefore 4.1.24.1.2Patch availableCNA
—apache-superset (PyPI)before 4.1.24.1.2Patch availableGHSA-8w7f-8pr9-xgwj
  • Apache Superset VendorApache Affected before 4.1.2 Fixed in 4.1.2 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 4.1.2 Fixed in 4.1.2 Patch available GHSA-8w7f-8pr9-xgwj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 4.1.2VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 4.1.2 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 4.1.2
  • Fix · GHSA-8w7f-8pr9-xgwj apache-superset (PyPI) Fixed in 4.1.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-48912
  2. 2026-10-03 Alias added: GHSA-8w7f-8pr9-xgwj

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources