WordPress WooCommerce Google Sheet Connector plugin <= 1.3.20 - Cross Site Request Forgery (CSRF) Vulnerability
Priority LOW 19CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in WesternDeal WooCommerce Google Sheet Connector wc-gsheetconnector allows Cross Site Request Forgery.This issue affects WooCommerce Google Sheet Connector: from n/a through <= 1.3.20.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00145 3rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WesternDeal | WooCommerce Google Sheet Connector | up to 1.3.20 | — | No fix listed | CNA |
- WooCommerce Google Sheet Connector VendorWesternDeal Affected up to 1.3.20 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54030
- 2026-10-03 Alias added: GHSA-4xq4-57g4-3phx
More WesternDeal vulnerabilities
- TI-2023-02190 Easy Digital Downloads Google Sheet Connector < 1.6.6 - Access Code Update via CSRF CVSS 3.1MEDIUM 5.4
- TI-2025-41588 WordPress WPForms Google Sheet Connector plugin <= 4.0.1 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
- TI-2013-05910 Directory traversal vulnerability in download-file.php in the Advanced Dewplayer plugin… CVSS 2.0MEDIUM 5.0
- TI-2025-07870 Missing authorization in WesternDeal GSheetConnector for Gravity Forms – Send Gravity… CVSS 3.1HIGH 8.8
- TI-2024-05250 CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update CVSS 3.1MEDIUM 6.5
- TI-2025-16634 WordPress GSheetConnector for Forminator Forms Plugin <= 1.0.12 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2025-54030 · CVE Program
- CVE-2025-54030 · NVD
- FIRST EPSS
- GHSA-4xq4-57g4-3phx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences