PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | before 1.30.0; 2.0.0 to before 2.1.12; 2.2.0 to before 2.4.0; 3.0.0 to before 3.10.0; 4.0.0 to before 5.0.0 | 1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0 | Patch available | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.30.0 | 1.30.0 | Patch available | GHSA-rx7m-68vc-ppxh |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.12 | 2.1.12 | Patch available | GHSA-rx7m-68vc-ppxh |
| — | phpoffice/phpspreadsheet (Packagist) | 2.2.0 to before 2.4.0 | 2.4.0 | Patch available | GHSA-rx7m-68vc-ppxh |
| — | phpoffice/phpspreadsheet (Packagist) | 3.0.0 to before 3.10.0 | 3.10.0 | Patch available | GHSA-rx7m-68vc-ppxh |
| — | phpoffice/phpspreadsheet (Packagist) | 4.0.0 to before 5.0.0 | 5.0.0 | Patch available | GHSA-rx7m-68vc-ppxh |
- PhpSpreadsheet VendorPHPOffice Affected before 1.30.0; 2.0.0 to before 2.1.12; 2.2.0 to before 2.4.0; 3.0.0 to before 3.10.0; 4.0.0 to before 5.0.0 Fixed in 1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0 Patch available CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.30.0 Fixed in 1.30.0 Patch available GHSA-rx7m-68vc-ppxh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.12 Fixed in 2.1.12 Patch available GHSA-rx7m-68vc-ppxh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.4.0 Fixed in 2.4.0 Patch available GHSA-rx7m-68vc-ppxh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.0.0 to before 3.10.0 Fixed in 3.10.0 Patch available GHSA-rx7m-68vc-ppxh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 4.0.0 to before 5.0.0 Fixed in 5.0.0 Patch available GHSA-rx7m-68vc-ppxh
Remediation
- Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0
- Fix · GHSA-rx7m-68vc-ppxh phpoffice/phpspreadsheet (Packagist) Fixed in 1.30.0 Advisory →
- Fix · GHSA-rx7m-68vc-ppxh phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.12 Advisory →
- Fix · GHSA-rx7m-68vc-ppxh phpoffice/phpspreadsheet (Packagist) Fixed in 2.4.0 Advisory →
- Fix · GHSA-rx7m-68vc-ppxh phpoffice/phpspreadsheet (Packagist) Fixed in 3.10.0 Advisory →
- Fix · GHSA-rx7m-68vc-ppxh phpoffice/phpspreadsheet (Packagist) Fixed in 5.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54370
- 2026-10-03 Alias added: GHSA-rx7m-68vc-ppxh
References
Other 8
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-rx7m-68vc-ppxh
- https://github.com/PHPOffice/PhpSpreadsheet/commit/334a67797ace574d1d37c0992ffe283b7415471a
- https://github.com/PHPOffice/PhpSpreadsheet/commit/4050f14521d70634c3320b170236574a6106eb39
- https://github.com/PHPOffice/PhpSpreadsheet/commit/81a0de2261f698404587a6421a5c6eb263c40b31
- https://github.com/PHPOffice/PhpSpreadsheet/commit/ac4befd2f7ccc21a59daef606a02a3d1828ade09
- https://github.com/PHPOffice/PhpSpreadsheet/commit/c2cd0e64392438e4c6af082796eb65c1d629a266
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpoffice/phpspreadsheet/CVE-2025-54370.yaml
- https://github.com/PHPOffice/PhpSpreadsheet
More PHPOffice vulnerabilities
- TI-2026-32885 PhpSpreadsheet: File::prohibitWrappers bypass CVSS 4.0CRITICAL 9.2
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2026-79412 PhpSpreadsheet ODS reader exhausts CPU and memory via repeated rows CVSS 4.0HIGH 8.7
- TI-2026-78784 Insecure deserialization in PHPOffice PHPPresentation allows code execution CVSS 4.0CRITICAL 9.2
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
Sources
- CVE-2025-54370 · CVE Program
- CVE-2025-54370 · NVD
- FIRST EPSS
- GHSA-rx7m-68vc-ppxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences