Read the docs

PhpSpreadsheet ODS reader exhausts CPU and memory via repeated rows

Priority HIGH 77CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Versions from 2.0.0 before 2.1.19, from 2.2.0 before 2.4.8, from 3.3.0 before 3.10.8, from 4.0.0 before 5.10.0, and before 1.30.7 are affected. Its ODS reader does not limit the table:number-rows-repeated attribute, so it creates a cell for every repeated row that contains a value (CWE-400). A remote attacker with no privileges and no user interaction can supply a small ODS file that consumes substantial CPU and memory and terminates the PHP worker.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0, Ods::processTableRow in src/PhpSpreadsheet/Reader/Ods.php accepts an unbounded table:number-rows-repeated attribute from an ODS table row. When the row contains a value, the reader materializes a cell for every repetition without checking the spreadsheet row limit, so a small attacker-controlled ODS file can consume substantial CPU and memory and terminate the PHP worker. Column repetition is separately bounded and is not part of this vulnerability. This issue is fixed in versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed PhpSpreadsheet (PHPOffice): 1.30.7, 2.1.19, 2.4.8 +2phpoffice/phpspreadsheet (Packagist): 5.10.0, 3.10.8, 2.4.8 +2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPOfficePhpSpreadsheetbefore 1.30.7; 2.0.0 to before 2.1.19; 2.2.0 to before 2.4.8; 3.3.0 to before 3.10.8; 4.0.0 to before 5.10.01.30.7, 2.1.19, 2.4.8, 3.10.8, 5.10.0Patch availableCNA
—phpoffice/phpspreadsheet (Packagist)4.0.0 to before 5.10.05.10.0Patch availableGHSA-j2w7-387v-m2rq
—phpoffice/phpspreadsheet (Packagist)3.3.0 to before 3.10.83.10.8Patch availableGHSA-j2w7-387v-m2rq
—phpoffice/phpspreadsheet (Packagist)2.2.0 to before 2.4.82.4.8Patch availableGHSA-j2w7-387v-m2rq
—phpoffice/phpspreadsheet (Packagist)2.0.0 to before 2.1.192.1.19Patch availableGHSA-j2w7-387v-m2rq
—phpoffice/phpspreadsheet (Packagist)before 1.30.71.30.7Patch availableGHSA-j2w7-387v-m2rq
  • PhpSpreadsheet VendorPHPOffice Affected before 1.30.7; 2.0.0 to before 2.1.19; 2.2.0 to before 2.4.8; 3.3.0 to before 3.10.8; 4.0.0 to before 5.10.0 Fixed in 1.30.7, 2.1.19, 2.4.8, 3.10.8, 5.10.0 Patch available CNA
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 4.0.0 to before 5.10.0 Fixed in 5.10.0 Patch available GHSA-j2w7-387v-m2rq
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.3.0 to before 3.10.8 Fixed in 3.10.8 Patch available GHSA-j2w7-387v-m2rq
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.4.8 Fixed in 2.4.8 Patch available GHSA-j2w7-387v-m2rq
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.19 Fixed in 2.1.19 Patch available GHSA-j2w7-387v-m2rq
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.30.7 Fixed in 1.30.7 Patch available GHSA-j2w7-387v-m2rq

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*——PHPOffice
  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions — — ·PHPOffice

Remediation

Upgrade PhpSpreadsheet to 1.30.7, 2.1.19, 2.4.8, 3.10.8 or 5.10.0, matching the release line in use. The Packagist package phpoffice/phpspreadsheet has the same fixed versions.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 1.30.7, 2.1.19, 2.4.8, 3.10.8, 5.10.0
  • Fix · GHSA-j2w7-387v-m2rq phpoffice/phpspreadsheet (Packagist) Fixed in 5.10.0 Advisory →
  • Fix · GHSA-j2w7-387v-m2rq phpoffice/phpspreadsheet (Packagist) Fixed in 3.10.8 Advisory →
  • Fix · GHSA-j2w7-387v-m2rq phpoffice/phpspreadsheet (Packagist) Fixed in 2.4.8 Advisory →
  • Fix · GHSA-j2w7-387v-m2rq phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.19 Advisory →
  • Fix · GHSA-j2w7-387v-m2rq phpoffice/phpspreadsheet (Packagist) Fixed in 1.30.7 Advisory →

Timeline

  1. 2026-10-22 Threatist record created from CVE-2026-108359
  2. 2026-10-23 Priority changed: MEDIUM → LOW
  3. 2026-10-27 Alias added: GHSA-j2w7-387v-m2rq
  4. 2026-10-29 CISA SSVC decision points changed
  5. 2026-10-29 Priority changed: LOW → HIGH
  6. 2026-10-30 EPSS moved to the 50th–90th percentile

References

  • TI-2026-32885 PhpSpreadsheet: File::prohibitWrappers bypass CVSS 4.0CRITICAL 9.2
  • TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
  • TI-2025-34182 PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser CVSS 4.0HIGH 8.7
  • TI-2026-78784 Insecure deserialization in PHPOffice PHPPresentation allows code execution CVSS 4.0CRITICAL 9.2
  • TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
  • TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
See all 37 →

Sources