Next.js Content Injection Vulnerability for Image Optimization
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 7 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 15.0.0 to before 15.4.5; before 14.2.31 | 15.4.5, 14.2.31 | Patch available | CNA |
| — | next (npm) | 0.9.9 to before 14.2.31 | 14.2.31 | Patch available | GHSA-xv57-4mr9-wg8v |
| — | next (npm) | 15.0.0 to before 15.4.5 | 15.4.5 | Patch available | GHSA-xv57-4mr9-wg8v |
- next.js Vendorvercel Affected 15.0.0 to before 15.4.5; before 14.2.31 Fixed in 15.4.5, 14.2.31 Patch available CNA
- next (npm) Vendor— Affected 0.9.9 to before 14.2.31 Fixed in 14.2.31 Patch available GHSA-xv57-4mr9-wg8v
- next (npm) Vendor— Affected 15.0.0 to before 15.4.5 Fixed in 15.4.5 Patch available GHSA-xv57-4mr9-wg8v
Remediation
- Fix · CNA next.js (vercel) Fixed in 15.4.5, 14.2.31
- Fix · GHSA-xv57-4mr9-wg8v next (npm) Fixed in 14.2.31 Advisory →
- Fix · GHSA-xv57-4mr9-wg8v next (npm) Fixed in 15.4.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Trusted Artifact Signer | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 2 | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-55173
- 2026-10-03 Alias added: GHSA-xv57-4mr9-wg8v
References
Advisory 3
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2025-55173 · CVE Program
- CVE-2025-55173 · NVD
- FIRST EPSS
- GHSA-xv57-4mr9-wg8v · GitHub Advisory Database · CC BY 4.0
- CVE-2025-55173 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences