Read the docs
TI-2025-35104 Aliases CVE-2025-55673GHSA-9g5x-mm39-wg9r

Apache Superset: Metadata exposure in embedded charts

Priority LOW 31CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user. This issue affects Apache Superset: before 4.1.3. Users are recommended to upgrade to version 4.1.3, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00609 49th percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 4.1.3apache-superset (PyPI): 4.1.3.post1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetbefore 4.1.34.1.3Patch availableCNA
—apache-superset (PyPI)before 4.1.3.post14.1.3.post1Patch availableGHSA-9g5x-mm39-wg9r
  • Apache Superset VendorApache Affected before 4.1.3 Fixed in 4.1.3 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 4.1.3.post1 Fixed in 4.1.3.post1 Patch available GHSA-9g5x-mm39-wg9r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 4.1.3VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 4.1.3 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 4.1.3
  • Fix · GHSA-9g5x-mm39-wg9r apache-superset (PyPI) Fixed in 4.1.3.post1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-55673
  2. 2026-10-03 Alias added: GHSA-9g5x-mm39-wg9r

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources