Read the docs
TI-2025-35699 Aliases CVE-2025-57816GHSA-fq34-xw6c-fphf

Fides Webserver API Rate Limiting Vulnerability in Proxied Environments

Priority LOW 34CWE-799Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass, Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-307 and CWE-770.

Summary

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Webserver API's built-in IP-based rate limiting is ineffective in environments with CDNs, proxies or load balancers. The system incorrectly applies rate limits based on directly connected infrastructure IPs rather than client IPs, and stores counters in-memory rather than in a shared store. This allows attackers to bypass intended rate limits and potentially cause denial of service. This vulnerability only affects deployments relying on Fides's built-in rate limiting for protection. Deployments using external rate limiting solutions (WAFs, API gateways, etc.) are not affected. Version 2.69.1 fixes the issue. There are no application-level workarounds. However, rate limiting may instead be implemented externally at the infrastructure level using a WAF, API Gateway, or similar technology.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00435 38th percentileScored 2026-11-07
Fix Fixed fides (ethyca): 2.69.1ethyca-fides (PyPI): 2.69.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ethycafidesbefore 2.69.12.69.1Patch availableCNA
—ethyca-fides (PyPI)before 2.69.12.69.1Patch availableGHSA-fq34-xw6c-fphf
  • fides Vendorethyca Affected before 2.69.1 Fixed in 2.69.1 Patch available CNA
  • ethyca-fides (PyPI) Vendor— Affected before 2.69.1 Fixed in 2.69.1 Patch available GHSA-fq34-xw6c-fphf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:*before 2.69.1Vulnerableethyca
  • cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:* Versions before 2.69.1 Vulnerable ·ethyca

Remediation

  • Fix · CNA fides (ethyca) Fixed in 2.69.1
  • Fix · GHSA-fq34-xw6c-fphf ethyca-fides (PyPI) Fixed in 2.69.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-57816
  2. 2026-10-03 Alias added: GHSA-fq34-xw6c-fphf

References

  • TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
  • TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
  • TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
  • TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
  • TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
See all 19 →

Sources