Read the docs
TI-2025-35745 Aliases CVE-2025-57891GHSA-rx74-v5v8-g93c

WordPress Recurring PayPal Donations Plugin <= 1.8 - Cross Site Scripting (XSS) Vulnerability

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpecommerce Recurring PayPal Donations recurring-donation allows Stored XSS.This issue affects Recurring PayPal Donations: from n/a through <= 1.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00182 7th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WPecommerce, AlexanderfoxcRecurring PayPal Donationsup to 1.8—No fix listedCNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-57891
  2. 2026-10-03 Alias added: GHSA-rx74-v5v8-g93c

References

  • TI-2022-03081 Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
  • TI-2020-17910 The easy-wp-smtp plugin before 1.4.4 for WordPress allows Administrator account takeover… CVSS 3.1HIGH 7.5
  • TI-2019-15244 Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update CVSS 3.1CRITICAL 9.8
  • TI-2022-20738 WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.1
  • TI-2024-01414 WP eCommerce <= 3.15.1 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2022-22633 WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion CVSS 3.1HIGH 8.7
See all 11 →

Sources