WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion
Priority LOW 39CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Auth. Path Traversal vulnerability in Easy WP SMTP plugin <= 1.5.1 at WordPress.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00896 59th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WPecommerce, Alexanderfoxc | Easy WP SMTP | up to 1.5.1 | — | No fix listed | CNA |
- Easy WP SMTP VendorWPecommerce, Alexanderfoxc Affected up to 1.5.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-ecommerce:easy_wp_smtp:*:*:*:*:*:wordpress:*:* | up to 1.5.1 | Vulnerable | WPecommerce, Alexanderfoxc |
- cpe:2.3:a:wp-ecommerce:easy_wp_smtp:*:*:*:*:*:wordpress:*:* Versions up to 1.5.1 Vulnerable ·WPecommerce, Alexanderfoxc
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-45829
- 2026-10-03 Alias added: GHSA-988c-m4m6-qgj2
References
More WPecommerce, Alexanderfoxc Easy Wp Smtp vulnerabilities
- TI-2022-03081 Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2020-17910 The easy-wp-smtp plugin before 1.4.4 for WordPress allows Administrator account takeover… CVSS 3.1HIGH 7.5
- TI-2019-15244 Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2022-20738 WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Remote Code Execution (RCE) CVSS 3.1CRITICAL 9.1
- TI-2022-22637 WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Directory Traversal CVSS 3.1MEDIUM 6.8
- TI-2017-05348 XSS exists in Easy WP SMTP (before 1.2.5), a WordPress Plugin, via the e-mail subject or body. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2022-45829 · CVE Program
- CVE-2022-45829 · NVD
- FIRST EPSS
- GHSA-988c-m4m6-qgj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences