Paymenter Vulnerable to Remote Code Execution via Public File Uploads
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Paymenter is a free and open-source webshop solution for hostings. Prior to version 1.2.11, the ticket attachments functionality in Paymenter allows a malicious authenticated user to upload arbitrary files. This could result in sensitive data extraction from the database, credentials being read from configuration files, and arbitrary system commands being run under the web server user context. This vulnerability was patched by commit 87c3db4 and was released under the version 1.2.11 tag without any other code modifications compared to version 1.2.10. If upgrading is not immediately possible, administrators can mitigate this vulnerability with one or more of the following measures: updating nginx config to download attachments instead of executing them or disallowing access to /storage/ fully using a WAF such as Cloudflare.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Paymenter | Paymenter | before 1.2.11 | 1.2.11 | Patch available | CNA |
| — | paymenter/paymenter (Packagist) | before 1.2.11 | 1.2.11 | Patch available | GHSA-5pm9-r2m8-rcmj |
- Paymenter VendorPaymenter Affected before 1.2.11 Fixed in 1.2.11 Patch available CNA
- paymenter/paymenter (Packagist) Vendor— Affected before 1.2.11 Fixed in 1.2.11 Patch available GHSA-5pm9-r2m8-rcmj
Remediation
- Fix · CNA Paymenter (Paymenter) Fixed in 1.2.11
- Fix · GHSA-5pm9-r2m8-rcmj paymenter/paymenter (Packagist) Fixed in 1.2.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58048
- 2026-10-03 Alias added: GHSA-5pm9-r2m8-rcmj
References
More Paymenter vulnerabilities
- TI-2026-34786 Paymenter: URL parameter injection bypasses paid plan limits at checkout CVSS 3.1HIGH 8.5
- TI-2026-32495 Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module CVSS 3.1MEDIUM 5.3
- TI-2026-50118 Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade) CVSS 3.1MEDIUM 6.5
- TI-2026-32497 Paymenter: Broken object level authorization via service reference manipulation on ticket creation CVSS 3.1MEDIUM 5.4
- TI-2026-39897 Paymenter: Race condition in payWithCredit() enables credit double-spend CVSS 3.1MEDIUM 5.3
- TI-2026-32496 Paymenter doesn't reset email verification status after email change CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-58048 · CVE Program
- CVE-2025-58048 · NVD
- FIRST EPSS
- GHSA-5pm9-r2m8-rcmj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences