Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. This value is passed directly into a server-side HTTP request via file_get_contents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal network destinations. This vulnerability allows remote unauthenticated attackers to induce server-side HTTP GET requests to arbitrary external or internal endpoints. Depending on network configuration, this may lead to: blind SSRF to external attacker-controlled systems, and potential access to internal network services No direct response data is returned to the attacker (blind SSRF), but the issue may still enable sensitive network probing or data exfiltration via side channels. This issue has been fixed in version 1.5.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Paymenter | Paymenter | before 1.5.0 | 1.5.0 | Patch available | CNA |
| — | paymenter/paymenter (Packagist) | before 1.5.0 | 1.5.0 | Patch available | GHSA-7wwh-xcc3-9fcg |
- Paymenter VendorPaymenter Affected before 1.5.0 Fixed in 1.5.0 Patch available CNA
- paymenter/paymenter (Packagist) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-7wwh-xcc3-9fcg
Remediation
- Fix · CNA Paymenter (Paymenter) Fixed in 1.5.0
- Fix · GHSA-7wwh-xcc3-9fcg paymenter/paymenter (Packagist) Fixed in 1.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44583
- 2026-10-03 Alias added: GHSA-7wwh-xcc3-9fcg
References
More Paymenter vulnerabilities
- TI-2025-35891 Paymenter Vulnerable to Remote Code Execution via Public File Uploads CVSS 3.1CRITICAL 10.0
- TI-2026-34786 Paymenter: URL parameter injection bypasses paid plan limits at checkout CVSS 3.1HIGH 8.5
- TI-2026-50118 Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade) CVSS 3.1MEDIUM 6.5
- TI-2026-32497 Paymenter: Broken object level authorization via service reference manipulation on ticket creation CVSS 3.1MEDIUM 5.4
- TI-2026-39897 Paymenter: Race condition in payWithCredit() enables credit double-spend CVSS 3.1MEDIUM 5.3
- TI-2026-32496 Paymenter doesn't reset email verification status after email change CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-44583 · CVE Program
- CVE-2026-44583 · NVD
- FIRST EPSS
- GHSA-7wwh-xcc3-9fcg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences