Paymenter: URL parameter injection bypasses paid plan limits at checkout
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.1, the checkout component improperly filters URL-writable properties, allowing authenticated users to inject arbitrary key-value pairs into server provisioning parameters. Because bundled server extensions prioritize these user-supplied properties over administrator-defined configurations, a regular user can override hosting plans and resource limits at checkout without special privileges. The Checkout Livewire component's $checkoutConfig property exposed via URL query parameters, only validating keys explicitly defined by an extension's configuration method, allowing any undefined injected keys to bypass validation entirely. These unsanitized keys are then stored directly in the database by the cart component and later passed to server extensions during provisioning, enabling user-injected data to override intended administrator settings. Depending on the active extension, this leads to unauthorized overrides of core resource limits (such as CPU, RAM, storage, or package tiers). No administrative privileges are required to exploit this vulnerability. This issue has been fixed in version 1.5.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Paymenter | Paymenter | before 1.5.1 | 1.5.1 | Patch available | CNA |
| — | paymenter/paymenter (Packagist) | before 1.5.1 | 1.5.1 | Patch available | GHSA-5q4q-834j-g8g4 |
- Paymenter VendorPaymenter Affected before 1.5.1 Fixed in 1.5.1 Patch available CNA
- paymenter/paymenter (Packagist) Vendor— Affected before 1.5.1 Fixed in 1.5.1 Patch available GHSA-5q4q-834j-g8g4
Remediation
- Fix · CNA Paymenter (Paymenter) Fixed in 1.5.1
- Fix · GHSA-5q4q-834j-g8g4 paymenter/paymenter (Packagist) Fixed in 1.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-47198
- 2026-10-03 Alias added: GHSA-5q4q-834j-g8g4
References
More Paymenter vulnerabilities
- TI-2025-35891 Paymenter Vulnerable to Remote Code Execution via Public File Uploads CVSS 3.1CRITICAL 10.0
- TI-2026-32495 Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module CVSS 3.1MEDIUM 5.3
- TI-2026-50118 Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade) CVSS 3.1MEDIUM 6.5
- TI-2026-32497 Paymenter: Broken object level authorization via service reference manipulation on ticket creation CVSS 3.1MEDIUM 5.4
- TI-2026-39897 Paymenter: Race condition in payWithCredit() enables credit double-spend CVSS 3.1MEDIUM 5.3
- TI-2026-32496 Paymenter doesn't reset email verification status after email change CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-47198 · CVE Program
- CVE-2026-47198 · NVD
- FIRST EPSS
- GHSA-5q4q-834j-g8g4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences