Paymenter: Broken object level authorization via service reference manipulation on ticket creation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service. The vulnerability requires authentication and does not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Successful exploitation could allow an authenticated user to: create support tickets referencing services belonging to other users, potentially cause support staff to interact with or review unrelated customer services. The vulnerability did not allow direct access to another user's service, modification of another user's service or retrieval of confidential service data through the vulnerable endpoint itself. This issue has been fixed in version 1.5.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Paymenter | Paymenter | before 1.5.0 | 1.5.0 | Patch available | CNA |
| — | paymenter/paymenter (Packagist) | before 1.5.0 | 1.5.0 | Patch available | GHSA-x93q-x9pc-w5hw |
- Paymenter VendorPaymenter Affected before 1.5.0 Fixed in 1.5.0 Patch available CNA
- paymenter/paymenter (Packagist) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-x93q-x9pc-w5hw
Remediation
- Fix · CNA Paymenter (Paymenter) Fixed in 1.5.0
- Fix · GHSA-x93q-x9pc-w5hw paymenter/paymenter (Packagist) Fixed in 1.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44585
- 2026-10-03 Alias added: GHSA-x93q-x9pc-w5hw
References
More Paymenter vulnerabilities
- TI-2025-35891 Paymenter Vulnerable to Remote Code Execution via Public File Uploads CVSS 3.1CRITICAL 10.0
- TI-2026-34786 Paymenter: URL parameter injection bypasses paid plan limits at checkout CVSS 3.1HIGH 8.5
- TI-2026-32495 Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module CVSS 3.1MEDIUM 5.3
- TI-2026-50118 Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade) CVSS 3.1MEDIUM 6.5
- TI-2026-39897 Paymenter: Race condition in payWithCredit() enables credit double-spend CVSS 3.1MEDIUM 5.3
- TI-2026-32496 Paymenter doesn't reset email verification status after email change CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-44585 · CVE Program
- CVE-2026-44585 · NVD
- FIRST EPSS
- GHSA-x93q-x9pc-w5hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences