n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | 1.24.0 to before 1.107.0 | 1.107.0 | Patch available | CNA |
| — | n8n (npm) | 1.24.0 to before 1.107.0 | 1.107.0 | Patch available | GHSA-mvh4-2cm2-6hpg |
- n8n Vendorn8n Affected 1.24.0 to before 1.107.0 Fixed in 1.107.0 Patch available CNA
- n8n (npm) Vendor— Affected 1.24.0 to before 1.107.0 Fixed in 1.107.0 Patch available GHSA-mvh4-2cm2-6hpg
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.107.0
- Fix · GHSA-mvh4-2cm2-6hpg n8n (npm) Fixed in 1.107.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58177
- 2026-10-03 Alias added: GHSA-mvh4-2cm2-6hpg
References
Advisory 2
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2025-58177 · CVE Program
- CVE-2025-58177 · NVD
- FIRST EPSS
- GHSA-mvh4-2cm2-6hpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences