auth0-PHP: Improper File Type Handling in Bulk User Import
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | laravel-auth0 | 3.3.0 to before 8.17.0 | 8.17.0 | Patch available | CNA |
| — | auth0/auth0-php (Packagist) | 3.3.0 to before 8.17.0 | 8.17.0 | Patch available | GHSA-9mh6-g99m-ppcw |
- laravel-auth0 Vendorauth0 Affected 3.3.0 to before 8.17.0 Fixed in 8.17.0 Patch available CNA
- auth0/auth0-php (Packagist) Vendor— Affected 3.3.0 to before 8.17.0 Fixed in 8.17.0 Patch available GHSA-9mh6-g99m-ppcw
Remediation
- Fix · CNA laravel-auth0 (auth0) Fixed in 8.17.0
- Fix · GHSA-9mh6-g99m-ppcw auth0/auth0-php (Packagist) Fixed in 8.17.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-58769
- 2026-10-03 Alias added: GHSA-9mh6-g99m-ppcw
References
Other 7
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw
- https://github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432
- https://github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x
- https://github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c
- https://github.com/auth0/auth0-PHP/releases/tag/8.17.0
- https://github.com/auth0/auth0-PHP
More auth0 vulnerabilities
- TI-2015-07615 Improper input validation in HackerOne jsonwebtoken node module CVSS 3.0CRITICAL 9.8
- TI-2025-29805 Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK CVSS 3.1CRITICAL 9.1
- TI-2025-31089 Auth0-PHP SDK Deserialization of Untrusted Data vulnerability CVSS 4.0CRITICAL 9.3
- TI-2020-06427 An issue was discovered in the Login by Auth0 plugin before 4.0.0 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2019-05387 Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-58769 · CVE Program
- CVE-2025-58769 · NVD
- FIRST EPSS
- GHSA-9mh6-g99m-ppcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences