Read the docs
TI-2025-37108 Aliases CVE-2025-59578GHSA-57jq-5vcg-vjgf

WordPress ShopMagic plugin <= 4.5.6 - Sensitive Data Exposure vulnerability

Priority LOW 32CWE-201Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-201.

Summary

Insertion of Sensitive Information Into Sent Data vulnerability in wpdesk ShopMagic shopmagic-for-woocommerce allows Retrieve Embedded Sensitive Data.This issue affects ShopMagic: from n/a through <= 4.5.6.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0031 24th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpdeskShopMagicup to 4.5.6—No fix listedCNA
  • ShopMagic Vendorwpdesk Affected up to 4.5.6 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-59578
  2. 2026-10-03 Alias added: GHSA-57jq-5vcg-vjgf

References

  • TI-2026-51484 WordPress Flexible Subscriptions plugin <= 1.8.1 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2020-18902 Flexible Checkout Fields for WooCommerce <= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update CVSS 3.1HIGH 7.2
  • TI-2026-83314 Sensitive data exposure in WordPress Flexible Chat plugin CVSS 3.1HIGH 7.5
  • TI-2026-73809 Local file inclusion in ShopMagic plugin lets attackers run PHP files CVSS 3.1HIGH 8.1
  • TI-2024-20643 WordPress Flexible Checkout Fields for WooCommerce plugin <= 4.1.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2024-12735 Flexible Wishlist for WooCommerce <= 1.2.25 - Unauthenticated Stored Cross-Site Scripting via wishlist_name Parameter CVSS 3.1HIGH 7.2
See all 25 →

Sources