JupyterLab LaTeX typesetter links did not enforce `noopener` attribute
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to version 4.4.8, links generated with LaTeX typesetters in Markdown files and Markdown cells in JupyterLab and Jupyter Notebook did not include the noopener attribute. This is deemed to have no impact on the default installations. Theoretically users of third-party LaTeX-rendering extensions could find themselves vulnerable to reverse tabnabbing attacks if links generated by those extensions included target=_blank (no such extensions are known at time of writing) and they were to click on a link generated in LaTeX (typically visibly different from other links). This issue has been patched in version 4.4.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | before 4.4.8 | 4.4.8 | Patch available | CNA |
| — | jupyterlab (PyPI) | before 4.4.8 | 4.4.8 | Patch available | GHSA-vvfj-2jqx-52jm |
- jupyterlab Vendorjupyterlab Affected before 4.4.8 Fixed in 4.4.8 Patch available CNA
- jupyterlab (PyPI) Vendor— Affected before 4.4.8 Fixed in 4.4.8 Patch available GHSA-vvfj-2jqx-52jm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | before 4.4.8 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions before 4.4.8 Vulnerable ·jupyterlab
Remediation
- Fix · CNA jupyterlab (jupyterlab) Fixed in 4.4.8
- Fix · GHSA-vvfj-2jqx-52jm jupyterlab (PyPI) Fixed in 4.4.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-59842
- 2026-10-03 Alias added: GHSA-vvfj-2jqx-52jm
References
More Jupyterlab vulnerabilities
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-30579 Improper input validation in jupyterlab CVSS 3.1HIGH 8.8
- TI-2021-12463 JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> CVSS 3.1CRITICAL 9.6
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
- TI-2024-29399 HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering CVSS 3.1HIGH 7.6
Sources
- CVE-2025-59842 · CVE Program
- CVE-2025-59842 · NVD
- FIRST EPSS
- GHSA-vvfj-2jqx-52jm · GitHub Advisory Database · CC BY 4.0
- CVE-2025-59842 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences