Read the docs
TI-2025-42713 Aliases CVE-2025-69262GHSA-2phv-j68v-wwqx

pnpm vulnerable to Command Injection via environment variable substitution

Priority HIGH 69CWE-78Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01041 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pnpm (pnpm): 10.27.0pnpm (npm): 10.27.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
pnpmpnpm6.25.0 to before 10.27.010.27.0Patch availableCNA
—pnpm (npm)6.25.0 to before 10.27.010.27.0Patch availableGHSA-2phv-j68v-wwqx
  • pnpm Vendorpnpm Affected 6.25.0 to before 10.27.0 Fixed in 10.27.0 Patch available CNA
  • pnpm (npm) Vendor— Affected 6.25.0 to before 10.27.0 Fixed in 10.27.0 Patch available GHSA-2phv-j68v-wwqx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pnpm:pnpm:*:*:*:*:*:node.js:*:*6.25.0 to before 10.27.0Vulnerablepnpm
  • cpe:2.3:a:pnpm:pnpm:*:*:*:*:*:node.js:*:* Versions 6.25.0 to before 10.27.0 Vulnerable ·pnpm

Remediation

  • Fix · CNA pnpm (pnpm) Fixed in 10.27.0
  • Fix · GHSA-2phv-j68v-wwqx pnpm (npm) Fixed in 10.27.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-69262
  2. 2026-10-03 Alias added: GHSA-2phv-j68v-wwqx

References

  • TI-2025-42715 pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" CVSS 3.1CRITICAL 9.8
  • TI-2023-19086 pnpm incorrectly parses tar archives relative to specification CVSS 3.1CRITICAL 9.8
  • TI-2026-40212 pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes CVSS 3.1HIGH 8.8
  • TI-2026-40211 pnpm: Repository-controlled configDependencies can select a pacquet native install engine CVSS 3.1HIGH 8.8
  • TI-2026-40042 pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle CVSS 3.1HIGH 8.8
  • TI-2026-36842 pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement CVSS 3.1HIGH 8.8
See all 27 →

Sources