Read the docs

pnpm

Records32All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high19CVSS 7.0–8.9

Exploited now

pnpm records in CISA KEV

No pnpm vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

32 records

Priority HIGH 69

pnpm versions 11.0.0 before 11.11.0 and 10.7.0 before 10.34.5 expand ${VAR} environment-variable placeholders in the httpProxy, httpsProxy, and noProxy settings read from a project's pnpm-workspace.yaml.

CVSS 4.0HIGH 8.3 Network No auth User interaction EPSS 0.00285 Published 2026-09-27 Partial fix · 11.11.0, 10.34.5 CWE-201
Priority MEDIUM 61

The package manager pnpm prior to version 9.15.0 seems to mishandle overrides and global cache: Overrides from one workspace leak into npm metadata saved in global cache; npm metadata from global cache affects other work…

CVSS 4.0MEDIUM 5.8 Network No auth User interaction EPSS 0.00977 Published 2024-12-10 Fixed in 9.15.0 CWE-426
Load more
Open these records in search →