Restore restriction bypass via key disclosure vulnerability (pgAdmin 4)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
pgAdmin versions 9.11 are affected by a Restore restriction bypass via key disclosure vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. An attacker with access to the pgAdmin web interface can observe an active restore operation, extract the `\restrict` key in real time, and race the restore process by overwriting the restore script with a payload that re-enables meta-commands using `\unrestrict <key>`. This results in reliable command execution on the pgAdmin host during the restore operation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | 9.11 | — | No fix listed | CNA |
| — | pgadmin4 (PyPI) | before 9.12 | 9.12 | Patch available | GHSA-3p7x-94q9-jq9x |
- pgAdmin 4 Vendorpgadmin.org Affected 9.11 Fixed in — No fix listed CNA
- pgadmin4 (PyPI) Vendor— Affected before 9.12 Fixed in 9.12 Patch available GHSA-3p7x-94q9-jq9x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:9.11:*:*:*:*:postgresql:*:* | 9.11 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:9.11:*:*:*:*:postgresql:*:* Versions 9.11 Vulnerable ·pgadmin.org
Remediation
- Fix · GHSA-3p7x-94q9-jq9x pgadmin4 (PyPI) Fixed in 9.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1707
- 2026-10-03 Alias added: GHSA-3p7x-94q9-jq9x
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-1707 · CVE Program
- CVE-2026-1707 · NVD
- FIRST EPSS
- GHSA-3p7x-94q9-jq9x · GitHub Advisory Database · CC BY 4.0
- CVE-2026-1707 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences