Arbitrary Code Execution in Language Servers for AWS
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Language Servers for AWS | before 1.65.0 | 1.65.0 | Patch available | CNA |
| — | @aws/lsp-codewhisperer (npm) | before 0.0.113 | 0.0.113 | Patch available | GHSA-xhcr-j4j9-3gh7 |
- Language Servers for AWS VendorAWS Affected before 1.65.0 Fixed in 1.65.0 Patch available CNA
- @aws/lsp-codewhisperer (npm) Vendor— Affected before 0.0.113 Fixed in 0.0.113 Patch available GHSA-xhcr-j4j9-3gh7
Remediation
- Fix · CNA Language Servers for AWS (Amazon Web Services) Fixed in 1.65.0
- Fix · GHSA-xhcr-j4j9-3gh7 @aws/lsp-codewhisperer (npm) Fixed in 0.0.113 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Amazon Web Services Language Servers for AWS — aws.amazon.com/security/security-bulletins/2026-047-aws
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-11027 Arbitrary file write in Language Servers for AWSPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12957
- 2026-10-03 Alias added: GHSA-xhcr-j4j9-3gh7
References
Advisory 3
Other 7
- https://github.com/Amazon-Q-Developer/language-servers/pull/2708
- https://github.com/Amazon-Q-Developer/language-servers/pull/2711
- https://github.com/Amazon-Q-Developer/language-servers/commit/7b8595a4e638562f79d5f71dcf22b0c700490458
- https://github.com/Amazon-Q-Developer/language-servers/commit/f5aa1a3b25aa38bfe8dd0e830b5839e1cea1d410
- https://aws.amazon.com/security/security-bulletins/2026-047-aws
- https://github.com/Amazon-Q-Developer/language-servers/releases/tag/agentic-rc-1.65.0
- https://github.com/aws/language-servers
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-12957 · CVE Program
- CVE-2026-12957 · NVD
- FIRST EPSS
- GHSA-xhcr-j4j9-3gh7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences