Arbitrary file write in Language Servers for AWS
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Language Servers for AWS | before 1.69.0 | 1.69.0 | Patch available | CNA |
| — | @aws/lsp-codewhisperer (npm) | before 0.0.117 | 0.0.117 | Patch available | GHSA-6v3r-4p5c-mrp5 |
- Language Servers for AWS VendorAWS Affected before 1.69.0 Fixed in 1.69.0 Patch available CNA
- @aws/lsp-codewhisperer (npm) Vendor— Affected before 0.0.117 Fixed in 0.0.117 Patch available GHSA-6v3r-4p5c-mrp5
Remediation
- Fix · CNA Language Servers for AWS (Amazon Web Services) Fixed in 1.69.0
- Fix · GHSA-6v3r-4p5c-mrp5 @aws/lsp-codewhisperer (npm) Fixed in 0.0.117 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Amazon Web Services Language Servers for AWS — aws.amazon.com/security/security-bulletins/2026-047-aws
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-11026 Arbitrary Code Execution in Language Servers for AWSPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-12958
- 2026-10-03 Alias added: GHSA-6v3r-4p5c-mrp5
References
Advisory 3
Other 6
- https://github.com/Amazon-Q-Developer/language-servers/pull/2742
- https://github.com/Amazon-Q-Developer/language-servers/commit/6c279b083cc192aa5df1f38c2c185576fd5234f5
- https://aws.amazon.com/security/security-bulletins/2026-047-aws
- https://github.com/Amazon-Q-Developer/language-servers/releases/tag/agentic-rc-1.69.0
- https://github.com/Amazon-Q-Developer/language-servers/releases/tag/lsp-codewhisperer/v0.0.117
- https://github.com/aws/language-servers
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-12958 · CVE Program
- CVE-2026-12958 · NVD
- FIRST EPSS
- GHSA-6v3r-4p5c-mrp5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences