Metabase channel test endpoint can reach internal local addresses
Priority LOW 11CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Metabase is an open-source data analytics platform. Prior to 55.13, 56.3, and 57.1, self-hosted Metabase instances that allow users to create subscriptions could be potentially impacted if their Metabase is colocated with other unsecured resources. This vulnerability is fixed in 55.13, 56.3, and 57.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0024 15th percentileScored 2026-11-07
Fix Fixed metabase (metabase): 57.1, 56.3, 55.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | 0.57.0-beta to before 57.1; 0.56.0-beta to before 56.3; before 55.13 | 57.1, 56.3, 55.13 | Patch available | CNA |
- metabase VendorMetabase Affected 0.57.0-beta to before 57.1; 0.56.0-beta to before 56.3; before 55.13 Fixed in 57.1, 56.3, 55.13 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* | before 0.55.13 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | before 1.55.13 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* | 0.56.0 to before 0.56.3 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | 1.56.0 to before 1.56.3 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:0.57.0:beta:*:*:-:*:*:* | 0.57.0 beta | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:1.57.0:beta:*:*:enterprise:*:*:* | 1.57.0 beta | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* Versions before 0.55.13 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions before 1.55.13 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* Versions 0.56.0 to before 0.56.3 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions 1.56.0 to before 1.56.3 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:0.57.0:beta:*:*:-:*:*:* Versions 0.57.0 beta Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:1.57.0:beta:*:*:enterprise:*:*:* Versions 1.57.0 beta Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 57.1, 56.3, 55.13
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22805
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences