Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-1333.
Summary
A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration. The affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue. Workarounds: ● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block requests containing excessively long sequences of backslashes or suspicious repeated patterns in the queries.extras.where parameter. ● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to reduce the impact of potential attacks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 6.0.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 6.0.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-19323 Apache Superset: Improper Authorization in Chart Update allowing Dashboard ModificationPriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23985
- 2026-10-03 Alias added: GHSA-92hr-7q6h-w7c4
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-23985 · CVE Program
- CVE-2026-23985 · NVD
- FIRST EPSS
- GHSA-92hr-7q6h-w7c4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences