Read the docs
TI-2026-20237 Aliases CVE-2026-25053GHSA-9g95-qf3f-ggrw

n8n is Vulnerable to OS Command Injection in Git Node

Priority MEDIUM 43CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

n8n is an open source workflow automation platform. Prior to versions 1.123.10 and 2.5.0, vulnerabilities in the Git node allowed authenticated users with permission to create or modify workflows to execute arbitrary system commands or read arbitrary files on the n8n host. This issue has been patched in versions 1.123.10 and 2.5.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00623 50th percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.10, 2.5.0n8n (npm): 2.5.0, 1.123.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.10; before 2.5.01.123.10, 2.5.0Patch availableCNA
—n8n (npm)2.0.0 to before 2.5.02.5.0Patch availableGHSA-9g95-qf3f-ggrw
—n8n (npm)before 1.123.101.123.10Patch availableGHSA-9g95-qf3f-ggrw
  • n8n Vendorn8n Affected before 1.123.10; before 2.5.0 Fixed in 1.123.10, 2.5.0 Patch available CNA
  • n8n (npm) Vendor— Affected 2.0.0 to before 2.5.0 Fixed in 2.5.0 Patch available GHSA-9g95-qf3f-ggrw
  • n8n (npm) Vendor— Affected before 1.123.10 Fixed in 1.123.10 Patch available GHSA-9g95-qf3f-ggrw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.0; 2.0.0 to before 2.5.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.0; 2.0.0 to before 2.5.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.10, 2.5.0
  • Fix · GHSA-9g95-qf3f-ggrw n8n (npm) Fixed in 2.5.0 Advisory →
  • Fix · GHSA-9g95-qf3f-ggrw n8n (npm) Fixed in 1.123.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-25053
  2. 2026-10-03 Alias added: GHSA-9g95-qf3f-ggrw
  3. 2026-10-25 EPSS moved to the 50th–90th percentile
  4. 2026-10-31 EPSS moved to the below the 50th percentile
  5. 2026-11-05 EPSS moved to the 50th–90th percentile

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources