Read the docs
TI-2026-21900 Aliases CVE-2026-27493GHSA-75g8-rv7v-32f7

n8n has Unauthenticated Expression Evaluation via Form Node

Priority MEDIUM 46CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, a second-order expression injection vulnerability existed in n8n's Form nodes that could allow an unauthenticated attacker to inject and evaluate arbitrary n8n expressions by submitting crafted form data. When chained with an expression sandbox escape, this could escalate to remote code execution on the n8n host. The vulnerability requires a specific workflow configuration to be exploitable. First, a form node with a field interpolating a value provided by an unauthenticated user, e.g. a form submitted value. Second, the field value must begin with an `=` character, which caused n8n to treat it as an expression and triggered a double-evaluation of the field content. There is no practical reason for a workflow designer to prefix a field with `=` intentionally — the character is not rendered in the output, so the result would not match the designer's expectations. If added accidentally, it would be noticeable and very unlikely to persist. An unauthenticated attacker would need to either know about this specific circumstance on a target instance or discover a matching form by chance. Even when the preconditions are met, the expression injection alone is limited to data accessible within the n8n expression context. Escalation to remote code execution requires chaining with a separate sandbox escape vulnerability. The issue has been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Review usage of form nodes manually for above mentioned preconditions, disable the Form node by adding `n8n-nodes-base.form` to the `NODES_EXCLUDE` environment variable, and/or disable the Form Trigger node by adding `n8n-nodes-base.formTrigger` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01386 72nd percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.22, 2.9.3, 2.10.1n8n (npm): 1.123.22, 2.9.3, 2.10.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.11.123.22, 2.9.3, 2.10.1Patch availableCNA
—n8n (npm)before 1.123.221.123.22Patch availableGHSA-75g8-rv7v-32f7
—n8n (npm)2.0.0 to before 2.9.32.9.3Patch availableGHSA-75g8-rv7v-32f7
—n8n (npm)2.10.0 to before 2.10.12.10.1Patch availableGHSA-75g8-rv7v-32f7
  • n8n Vendorn8n Affected before 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.1 Fixed in 1.123.22, 2.9.3, 2.10.1 Patch available CNA
  • n8n (npm) Vendor— Affected before 1.123.22 Fixed in 1.123.22 Patch available GHSA-75g8-rv7v-32f7
  • n8n (npm) Vendor— Affected 2.0.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-75g8-rv7v-32f7
  • n8n (npm) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-75g8-rv7v-32f7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.1Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.1 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.22, 2.9.3, 2.10.1
  • Fix · GHSA-75g8-rv7v-32f7 n8n (npm) Fixed in 1.123.22 Advisory →
  • Fix · GHSA-75g8-rv7v-32f7 n8n (npm) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-75g8-rv7v-32f7 n8n (npm) Fixed in 2.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-27493
  2. 2026-10-03 Alias added: GHSA-75g8-rv7v-32f7

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources