n8n Vulnerable to Stored XSS via Various Nodes
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover. The issues have been fixed in n8n versions 2.10.1 and 1.123.21. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Webhook node by adding `n8n-nodes-base.webhook` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.1 | 1.123.22, 2.9.3, 2.10.1 | Patch available | CNA |
| — | n8n (npm) | before 1.123.22 | 1.123.22 | Patch available | GHSA-2p9h-rqjw-gm92 |
| — | n8n (npm) | 2.0.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-2p9h-rqjw-gm92 |
| — | n8n (npm) | 2.10.0 to before 2.10.1 | 2.10.1 | Patch available | GHSA-2p9h-rqjw-gm92 |
- n8n Vendorn8n Affected before 1.123.22; 2.0.0 to before 2.9.3; 2.10.0 to before 2.10.1 Fixed in 1.123.22, 2.9.3, 2.10.1 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.22 Fixed in 1.123.22 Patch available GHSA-2p9h-rqjw-gm92
- n8n (npm) Vendor— Affected 2.0.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-2p9h-rqjw-gm92
- n8n (npm) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-2p9h-rqjw-gm92
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.22, 2.9.3, 2.10.1
- Fix · GHSA-2p9h-rqjw-gm92 n8n (npm) Fixed in 1.123.22 Advisory →
- Fix · GHSA-2p9h-rqjw-gm92 n8n (npm) Fixed in 2.9.3 Advisory →
- Fix · GHSA-2p9h-rqjw-gm92 n8n (npm) Fixed in 2.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27578
- 2026-10-03 Alias added: GHSA-2p9h-rqjw-gm92
References
Patch 3
Advisory 2
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-27578 · CVE Program
- CVE-2026-27578 · NVD
- FIRST EPSS
- GHSA-2p9h-rqjw-gm92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences