Next.js: HTTP request smuggling in rewrites
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Next.js is a React framework for building full-stack web applications. Starting in version 9.5.0 and prior to versions 15.5.13 and 16.1.7, when Next.js rewrites proxy traffic to an external backend, a crafted `DELETE`/`OPTIONS` request using `Transfer-Encoding: chunked` could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel. The vulnerability originated in an upstream library vendored by Next.js. It is fixed in Next.js 15.5.13 and 16.1.7 by updating that dependency’s behavior so `content-length: 0` is added only when both `content-length` and `transfer-encoding` are absent, and `transfer-encoding` is no longer removed in that code path. If upgrading is not immediately possible, block chunked `DELETE`/`OPTIONS` requests on rewritten routes at the edge/proxy, and/or enforce authentication/authorization on backend routes.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 16.0.0-beta.0 to before 16.1.7; 9.5.0 to before 15.5.13 | 16.1.7, 15.5.13 | Patch available | CNA |
| — | next (npm) | 16.0.0-beta.0 to before 16.1.7 | 16.1.7 | Patch available | GHSA-ggv3-7p47-pfv8 |
| — | next (npm) | 9.5.0 to before 15.5.13 | 15.5.13 | Patch available | GHSA-ggv3-7p47-pfv8 |
- next.js Vendorvercel Affected 16.0.0-beta.0 to before 16.1.7; 9.5.0 to before 15.5.13 Fixed in 16.1.7, 15.5.13 Patch available CNA
- next (npm) Vendor— Affected 16.0.0-beta.0 to before 16.1.7 Fixed in 16.1.7 Patch available GHSA-ggv3-7p47-pfv8
- next (npm) Vendor— Affected 9.5.0 to before 15.5.13 Fixed in 15.5.13 Patch available GHSA-ggv3-7p47-pfv8
Remediation
- Fix · CNA next.js (vercel) Fixed in 16.1.7, 15.5.13
- Fix · GHSA-ggv3-7p47-pfv8 next (npm) Fixed in 16.1.7 Advisory →
- Fix · GHSA-ggv3-7p47-pfv8 next (npm) Fixed in 15.5.13 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat Trusted Artifact Signer | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 2 | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-29057
- 2026-10-03 Alias added: GHSA-ggv3-7p47-pfv8
References
Advisory 2
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2026-29057 · CVE Program
- CVE-2026-29057 · NVD
- FIRST EPSS
- GHSA-ggv3-7p47-pfv8 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-29057 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences