Read the docs
TI-2026-24382 Aliases CVE-2026-31829GHSA-fvcw-9w9r-pxc7

Flowise affected by Server-Side Request Forgery (SSRF) in HTTP Node Leading to Internal Network Access

Priority HIGH 73CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.0.13, Flowise exposes an HTTP Node in AgentFlow and Chatflow that performs server-side HTTP requests using user-controlled URLs. By default, there are no restrictions on target hosts, including private/internal IP ranges (RFC 1918), localhost, or cloud metadata endpoints. This enables Server-Side Request Forgery (SSRF), allowing any user interacting with a publicly exposed chatflow to force the Flowise server to make requests to internal network resources that are inaccessible from the public internet. This vulnerability is fixed in 3.0.13.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02691 85th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.0.13flowise (npm): 3.0.13+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowisebefore 3.0.133.0.13Patch availableCNA
—flowise (npm)before 3.0.133.0.13Patch availableGHSA-fvcw-9w9r-pxc7
—flowise-components (npm)before 3.0.133.0.13Patch availableGHSA-fvcw-9w9r-pxc7
  • Flowise VendorFlowiseAI Affected before 3.0.13 Fixed in 3.0.13 Patch available CNA
  • flowise (npm) Vendor— Affected before 3.0.13 Fixed in 3.0.13 Patch available GHSA-fvcw-9w9r-pxc7
  • flowise-components (npm) Vendor— Affected before 3.0.13 Fixed in 3.0.13 Patch available GHSA-fvcw-9w9r-pxc7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*before 3.0.13VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions before 3.0.13 Vulnerable ·FlowiseAI

Remediation

  • Fix · CNA Flowise (FlowiseAI) Fixed in 3.0.13
  • Fix · GHSA-fvcw-9w9r-pxc7 flowise (npm) Fixed in 3.0.13 Advisory →
  • Fix · GHSA-fvcw-9w9r-pxc7 flowise-components (npm) Fixed in 3.0.13 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-31829
  2. 2026-10-03 Alias added: GHSA-fvcw-9w9r-pxc7
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources