Read the docs
TI-2026-24805 Aliases CVE-2026-32276GHSA-hxqw-6qv7-cqfv

Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin

Priority MEDIUM 40CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00471 41st percentileScored 2026-11-07
Fix Fixed connect-cms (opensource-workshop): 1.41.1, 2.41.1opensource-workshop/connect-cms (Packagist): 1.41.1, 2.41.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opensource-workshopconnect-cmsbefore 1.41.1; 2.0.0 to before 2.41.11.41.1, 2.41.1Patch availableCNA
—opensource-workshop/connect-cms (Packagist)before 1.41.11.41.1Patch availableGHSA-hxqw-6qv7-cqfv
—opensource-workshop/connect-cms (Packagist)2.0.0 to before 2.41.12.41.1Patch availableGHSA-hxqw-6qv7-cqfv
  • connect-cms Vendoropensource-workshop Affected before 1.41.1; 2.0.0 to before 2.41.1 Fixed in 1.41.1, 2.41.1 Patch available CNA
  • opensource-workshop/connect-cms (Packagist) Vendor— Affected before 1.41.1 Fixed in 1.41.1 Patch available GHSA-hxqw-6qv7-cqfv
  • opensource-workshop/connect-cms (Packagist) Vendor— Affected 2.0.0 to before 2.41.1 Fixed in 2.41.1 Patch available GHSA-hxqw-6qv7-cqfv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:*1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1Vulnerableopensource-workshop
  • cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1 Vulnerable ·opensource-workshop

Remediation

  • Fix · CNA connect-cms (opensource-workshop) Fixed in 1.41.1, 2.41.1
  • Fix · GHSA-hxqw-6qv7-cqfv opensource-workshop/connect-cms (Packagist) Fixed in 1.41.1 Advisory →
  • Fix · GHSA-hxqw-6qv7-cqfv opensource-workshop/connect-cms (Packagist) Fixed in 2.41.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-32276
  2. 2026-10-03 Alias added: GHSA-hxqw-6qv7-cqfv
  3. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2026-24806 Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View CVSS 3.1HIGH 8.7
  • TI-2026-24828 Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature CVSS 3.1HIGH 7.5
  • TI-2026-24829 Improper authorization in opensource-workshop connect-cms CVSS 3.1HIGH 8.1
  • TI-2026-24807 Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin CVSS 3.1HIGH 8.2
  • TI-2026-24808 Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin CVSS 3.1MEDIUM 6.8

Sources