Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Priority LOW 37CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution, Cross-site scripting
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434 and CWE-79.
Summary
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.002 9th percentileScored 2026-11-07
Fix Fixed connect-cms (opensource-workshop): 1.41.1, 2.41.1opensource-workshop/connect-cms (Packagist): 1.41.1, 2.41.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| opensource-workshop | connect-cms | before 1.41.1; 2.0.0 to before 2.41.1 | 1.41.1, 2.41.1 | Patch available | CNA |
| — | opensource-workshop/connect-cms (Packagist) | before 1.41.1 | 1.41.1 | Patch available | GHSA-mv3p-7p89-wq9p |
| — | opensource-workshop/connect-cms (Packagist) | 2.0.0 to before 2.41.1 | 2.41.1 | Patch available | GHSA-mv3p-7p89-wq9p |
- connect-cms Vendoropensource-workshop Affected before 1.41.1; 2.0.0 to before 2.41.1 Fixed in 1.41.1, 2.41.1 Patch available CNA
- opensource-workshop/connect-cms (Packagist) Vendor— Affected before 1.41.1 Fixed in 1.41.1 Patch available GHSA-mv3p-7p89-wq9p
- opensource-workshop/connect-cms (Packagist) Vendor— Affected 2.0.0 to before 2.41.1 Fixed in 2.41.1 Patch available GHSA-mv3p-7p89-wq9p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* | 1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1 | Vulnerable | opensource-workshop |
- cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1 Vulnerable ·opensource-workshop
Remediation
- Fix · CNA connect-cms (opensource-workshop) Fixed in 1.41.1, 2.41.1
- Fix · GHSA-mv3p-7p89-wq9p opensource-workshop/connect-cms (Packagist) Fixed in 1.41.1 Advisory →
- Fix · GHSA-mv3p-7p89-wq9p opensource-workshop/connect-cms (Packagist) Fixed in 2.41.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32278
- 2026-10-03 Alias added: GHSA-mv3p-7p89-wq9p
References
Patch 1
Advisory 2
More opensource-workshop Connect-cms vulnerabilities
- TI-2026-24806 Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View CVSS 3.1HIGH 8.7
- TI-2026-24805 Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin CVSS 3.1HIGH 8.8
- TI-2026-24828 Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature CVSS 3.1HIGH 7.5
- TI-2026-24829 Improper authorization in opensource-workshop connect-cms CVSS 3.1HIGH 8.1
- TI-2026-24808 Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin CVSS 3.1MEDIUM 6.8
Sources
- CVE-2026-32278 · CVE Program
- CVE-2026-32278 · NVD
- FIRST EPSS
- GHSA-mv3p-7p89-wq9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences