Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
Priority MEDIUM 40CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00332 26th percentileScored 2026-11-07
Fix Fixed connect-cms (opensource-workshop): 1.41.1, 2.41.1opensource-workshop/connect-cms (Packagist): 1.41.1, 2.41.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| opensource-workshop | connect-cms | 1.35.0 to before 1.41.1; 2.35.0 to before 2.41.1 | 1.41.1, 2.41.1 | Patch available | CNA |
| — | opensource-workshop/connect-cms (Packagist) | 1.35.0 to before 1.41.1 | 1.41.1 | Patch available | GHSA-cmfh-mpmf-fmq4 |
| — | opensource-workshop/connect-cms (Packagist) | 2.35.0 to before 2.41.1 | 2.41.1 | Patch available | GHSA-cmfh-mpmf-fmq4 |
- connect-cms Vendoropensource-workshop Affected 1.35.0 to before 1.41.1; 2.35.0 to before 2.41.1 Fixed in 1.41.1, 2.41.1 Patch available CNA
- opensource-workshop/connect-cms (Packagist) Vendor— Affected 1.35.0 to before 1.41.1 Fixed in 1.41.1 Patch available GHSA-cmfh-mpmf-fmq4
- opensource-workshop/connect-cms (Packagist) Vendor— Affected 2.35.0 to before 2.41.1 Fixed in 2.41.1 Patch available GHSA-cmfh-mpmf-fmq4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* | 1.35.0 to before 1.41.1; 2.35.0 to before 2.41.1 | Vulnerable | opensource-workshop |
- cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* Versions 1.35.0 to before 1.41.1; 2.35.0 to before 2.41.1 Vulnerable ·opensource-workshop
Remediation
- Fix · CNA connect-cms (opensource-workshop) Fixed in 1.41.1, 2.41.1
- Fix · GHSA-cmfh-mpmf-fmq4 opensource-workshop/connect-cms (Packagist) Fixed in 1.41.1 Advisory →
- Fix · GHSA-cmfh-mpmf-fmq4 opensource-workshop/connect-cms (Packagist) Fixed in 2.41.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32277
- 2026-10-03 Alias added: GHSA-cmfh-mpmf-fmq4
References
Patch 1
Advisory 2
More opensource-workshop Connect-cms vulnerabilities
- TI-2026-24805 Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin CVSS 3.1HIGH 8.8
- TI-2026-24828 Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature CVSS 3.1HIGH 7.5
- TI-2026-24829 Improper authorization in opensource-workshop connect-cms CVSS 3.1HIGH 8.1
- TI-2026-24807 Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin CVSS 3.1HIGH 8.2
- TI-2026-24808 Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin CVSS 3.1MEDIUM 6.8
Sources
- CVE-2026-32277 · CVE Program
- CVE-2026-32277 · NVD
- FIRST EPSS
- GHSA-cmfh-mpmf-fmq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences