Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Server-Side Request Forgery (SSRF) issue exists in the external page migration feature of the Page Management Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| opensource-workshop | connect-cms | before 1.41.1; 2.0.0 to before 2.41.1 | 1.41.1, 2.41.1 | Patch available | CNA |
| — | opensource-workshop/connect-cms (Packagist) | before 1.41.1 | 1.41.1 | Patch available | GHSA-jh46-85jr-6ph9 |
| — | opensource-workshop/connect-cms (Packagist) | 2.0.0 to before 2.41.1 | 2.41.1 | Patch available | GHSA-jh46-85jr-6ph9 |
- connect-cms Vendoropensource-workshop Affected before 1.41.1; 2.0.0 to before 2.41.1 Fixed in 1.41.1, 2.41.1 Patch available CNA
- opensource-workshop/connect-cms (Packagist) Vendor— Affected before 1.41.1 Fixed in 1.41.1 Patch available GHSA-jh46-85jr-6ph9
- opensource-workshop/connect-cms (Packagist) Vendor— Affected 2.0.0 to before 2.41.1 Fixed in 2.41.1 Patch available GHSA-jh46-85jr-6ph9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* | 1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1 | Vulnerable | opensource-workshop |
- cpe:2.3:a:opensource-workshop:connect-cms:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.41.1; 2.0.0 to before 2.41.1 Vulnerable ·opensource-workshop
Remediation
- Fix · CNA connect-cms (opensource-workshop) Fixed in 1.41.1, 2.41.1
- Fix · GHSA-jh46-85jr-6ph9 opensource-workshop/connect-cms (Packagist) Fixed in 1.41.1 Advisory →
- Fix · GHSA-jh46-85jr-6ph9 opensource-workshop/connect-cms (Packagist) Fixed in 2.41.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32279
- 2026-10-03 Alias added: GHSA-jh46-85jr-6ph9
References
Patch 2
Advisory 2
More opensource-workshop Connect-cms vulnerabilities
- TI-2026-24806 Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View CVSS 3.1HIGH 8.7
- TI-2026-24805 Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin CVSS 3.1HIGH 8.8
- TI-2026-24828 Connect CMS: Information Disclosure Due to Improper Authorization through the Page Content Retrieval Feature CVSS 3.1HIGH 7.5
- TI-2026-24829 Improper authorization in opensource-workshop connect-cms CVSS 3.1HIGH 8.1
- TI-2026-24807 Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin CVSS 3.1HIGH 8.2
Sources
- CVE-2026-32279 · CVE Program
- CVE-2026-32279 · NVD
- FIRST EPSS
- GHSA-jh46-85jr-6ph9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences