Concurrent modification of RPZ data can lead to denial of servce
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Having many concurrent transfers of the same RPZ can lead to inconsistent RPZ data, use after free and/or a crash of the recursor. Normally concurrent transfers of the same RPZ zone can only occur with a malfunctioning RPZ provider.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | Recursor | 5.4.0 to before 5.4.1; 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.9 | 5.4.1, 5.3.6, 5.2.9 | Patch available | CNA |
- Recursor VendorPowerDNS Affected 5.4.0 to before 5.4.1; 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.9 Fixed in 5.4.1, 5.3.6, 5.2.9 Patch available CNA
Remediation
- Fix · CNA Recursor (PowerDNS) Fixed in 5.4.1, 5.3.6, 5.2.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PowerDNS Recursor 5.2.9, 5.3.6, 5.4.1
9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-25675 Crafted zones can cause increased resource usagePriority MEDIUM 40
- TI-2026-25673 Unbounded memory allocation by internal web serverPriority MEDIUM 40
- TI-2026-25677 Insufficient input validation of internal webserverPriority LOW 39
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33259
- 2026-10-03 Alias added: GHSA-6c6h-9v3q-3wqm
References
More PowerDNS Recursor vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
- TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
- TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2026-33259 · CVE Program
- CVE-2026-33259 · NVD
- FIRST EPSS
- GHSA-6c6h-9v3q-3wqm · GitHub Advisory Database · CC BY 4.0
- CVE-2026-33259 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences