Read the docs
TI-2026-26040 Aliases CVE-2026-33660GHSA-58qr-rcgv-642v

n8n Has Multiple Remote Code Execution Vulnerabilities in Merge Node AlaSQL SQL Mode

Priority MEDIUM 50CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution, SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94 and CWE-89.

Summary

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the instance. The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.26. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00968 62nd percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.27, 2.13.3n8n (npm): 2.14.1, 2.13.3, 1.123.27

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.27; 2.0.0-rc.0 to before 2.13.3; = 2.14.01.123.27, 2.13.3Patch availableCNA
—n8n (npm)2.14.0 to before 2.14.12.14.1Patch availableGHSA-58qr-rcgv-642v
—n8n (npm)2.0.0-rc.0 to before 2.13.32.13.3Patch availableGHSA-58qr-rcgv-642v
—n8n (npm)before 1.123.271.123.27Patch availableGHSA-58qr-rcgv-642v
  • n8n Vendorn8n Affected before 1.123.27; 2.0.0-rc.0 to before 2.13.3; = 2.14.0 Fixed in 1.123.27, 2.13.3 Patch available CNA
  • n8n (npm) Vendor— Affected 2.14.0 to before 2.14.1 Fixed in 2.14.1 Patch available GHSA-58qr-rcgv-642v
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.13.3 Fixed in 2.13.3 Patch available GHSA-58qr-rcgv-642v
  • n8n (npm) Vendor— Affected before 1.123.27 Fixed in 1.123.27 Patch available GHSA-58qr-rcgv-642v

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.27; 2.0.0 to before 2.13.3Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:*:node.js:*:*2.14.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.27; 2.0.0 to before 2.13.3 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:*:node.js:*:* Versions 2.14.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.27, 2.13.3
  • Fix · GHSA-58qr-rcgv-642v n8n (npm) Fixed in 2.14.1 Advisory →
  • Fix · GHSA-58qr-rcgv-642v n8n (npm) Fixed in 2.13.3 Advisory →
  • Fix · GHSA-58qr-rcgv-642v n8n (npm) Fixed in 1.123.27 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33660
  2. 2026-10-03 Alias added: GHSA-58qr-rcgv-642v

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources