Read the docs
TI-2026-26043 Aliases CVE-2026-33663GHSA-m63j-689w-3j35

n8n Vulnerable to Credential Theft via Name-Based Resolution and Permission Checker Bypass in Community Edition

Priority LOW 37CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.

Summary

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.27, an authenticated user with the `global:member` role could exploit chained authorization flaws in n8n's credential pipeline to steal plaintext secrets from generic HTTP credentials (`httpBasicAuth`, `httpHeaderAuth`, `httpQueryAuth`) belonging to other users on the same instance. The attack abuses a name-based credential resolution path that does not enforce ownership or project scope, combined with a bypass in the credentials permission checker that causes generic HTTP credential types to be skipped during pre-execution validation. Together, these flaws allow a member-role user to resolve another user's credential ID and execute a workflow that decrypts and uses that credential without authorization. Native integration credential types (e.g. `slackApi`, `openAiApi`, `postgres`) are not affected by this issue. This vulnerability affects Community Edition only. Enterprise Edition has additional permission gates on workflow creation and execution that independently block this attack chain. The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Restrict instance access to fully trusted users only, and/or audit credentials stored on the instance and rotate any generic HTTP credentials (`httpBasicAuth`, `httpHeaderAuth`, `httpQueryAuth`) that may have been exposed. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00399 34th percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.27, 2.13.3n8n (npm): 1.123.27, 2.14.1, 2.13.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.27; 2.0.0-rc.0 to before 2.13.3; = 2.14.01.123.27, 2.13.3Patch availableCNA
—n8n (npm)before 1.123.271.123.27Patch availableGHSA-m63j-689w-3j35
—n8n (npm)2.14.0 to before 2.14.12.14.1Patch availableGHSA-m63j-689w-3j35
—n8n (npm)2.0.0-rc.0 to before 2.13.32.13.3Patch availableGHSA-m63j-689w-3j35
  • n8n Vendorn8n Affected before 1.123.27; 2.0.0-rc.0 to before 2.13.3; = 2.14.0 Fixed in 1.123.27, 2.13.3 Patch available CNA
  • n8n (npm) Vendor— Affected before 1.123.27 Fixed in 1.123.27 Patch available GHSA-m63j-689w-3j35
  • n8n (npm) Vendor— Affected 2.14.0 to before 2.14.1 Fixed in 2.14.1 Patch available GHSA-m63j-689w-3j35
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.13.3 Fixed in 2.13.3 Patch available GHSA-m63j-689w-3j35

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:*before 1.123.27; 2.0.0 to before 2.13.3Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:community:node.js:*:*2.14.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.27; 2.0.0 to before 2.13.3 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:community:node.js:*:* Versions 2.14.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.27, 2.13.3
  • Fix · GHSA-m63j-689w-3j35 n8n (npm) Fixed in 1.123.27 Advisory →
  • Fix · GHSA-m63j-689w-3j35 n8n (npm) Fixed in 2.14.1 Advisory →
  • Fix · GHSA-m63j-689w-3j35 n8n (npm) Fixed in 2.13.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33663
  2. 2026-10-03 Alias added: GHSA-m63j-689w-3j35

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources