Metabase vulnerable to RCE and Arbitrary File Read via H2 JDBC INIT Injection in EE Serialization Import
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Metabase is an open source business intelligence and embedded analytics tool. In Metabase Enterprise prior to versions 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, and 1.59.4, authenticated admins on Metabase Enterprise Edition can achieve Remote Code Execution (RCE) and Arbitrary File Read via the `POST /api/ee/serialization/import` endpoint. A crafted serialization archive injects an `INIT` property into the H2 JDBC spec, which can execute arbitrary SQL during a database sync. We confirmed this was possible on Metabase Cloud. This only affects Metabase Enterprise. Metabase OSS lacks the affected codepaths. All versions of Metabase Enterprise that have serialization, which dates back to at least version 1.47, are affected. Metabase Enterprise versions 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, and 1.59.4 patch the issue. As a workaround, disable the serialization import endpoint in their Metabase instance to prevent access to the vulnerable codepaths.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | before 1.54.22; 1.55.0 to before 1.55.22; 1.56.0 to before 1.56.22; 1.57.0 to before 1.57.16; 1.58.0 to before 1.58.10; 1.59.0 to before 1.59.4 | 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, 1.59.4 | Patch available | CNA |
- metabase VendorMetabase Affected before 1.54.22; 1.55.0 to before 1.55.22; 1.56.0 to before 1.56.22; 1.57.0 to before 1.57.16; 1.58.0 to before 1.58.10; 1.59.0 to before 1.59.4 Fixed in 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, 1.59.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | before 1.54.22; 1.55.0 to before 1.55.22; 1.56.0 to before 1.56.22; 1.57.0 to before 1.57.16; 1.58.0 to before 1.58.10; 1.59.0 to before 1.59.4 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions before 1.54.22; 1.55.0 to before 1.55.22; 1.56.0 to before 1.56.22; 1.57.0 to before 1.57.16; 1.58.0 to before 1.58.10; 1.59.0 to before 1.59.4 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, 1.59.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33725
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences