LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BerriAI | litellm | before 1.83.0 | 1.83.0 | Patch available | CNA |
| — | litellm (PyPI) | before 1.83.0 | 1.83.0 | Patch available | GHSA-53mr-6c8q-9789 |
- litellm VendorBerriAI Affected before 1.83.0 Fixed in 1.83.0 Patch available CNA
- litellm (PyPI) Vendor— Affected before 1.83.0 Fixed in 1.83.0 Patch available GHSA-53mr-6c8q-9789
Remediation
- Fix · CNA litellm (BerriAI) Fixed in 1.83.0
- Fix · GHSA-53mr-6c8q-9789 litellm (PyPI) Fixed in 1.83.0 Advisory →
Red Hat 3 advisories
- RHSA-2026:30056 Released 2026-06-25 · Red Hat rating ImportantRHOAI 3.3.4 - Red Hat OpenShift AI
- Red Hat OpenShift AI 3.3 registry.redhat.io/rhoai/odh-llama-stack-core-rhel9
- RHSA-2026:28960 Released 2026-06-24 · Red Hat rating ImportantRHOAI 2.25.8 - Red Hat OpenShift AI
- Red Hat OpenShift AI 2.25 registry.redhat.io/rhoai/odh-llama-stack-core-rhel9
- RHSA-2026:13545 Released 2026-05-04 · Red Hat rating ImportantRed Hat Ansible Automation Platform 2.6 Container Release Update
- Red Hat Ansible Automation Platform 2.6 registry.redhat.io/ansible-automation-platform-26/ansible-dev-tools-rhel9, registry.redhat.io/ansible-automation-platform-26/controller-rhel9, registry.redhat.io/ansible-automation-platform-26/eda-controller-rhel9 +11
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Lightspeed Core | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2.6 | Fixed | RHSA-2026:13545 |
| Red Hat OpenShift AI 2.25 | Fixed | RHSA-2026:28960 |
| Red Hat OpenShift AI 3.3 | Fixed | RHSA-2026:30056 |
Not affected: 4 products
- Red Hat Ansible Automation Platform 2.6
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift AI 2.25
- Red Hat OpenShift AI 3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-35029
- 2026-10-03 Alias added: GHSA-53mr-6c8q-9789
- 2026-10-25 EPSS moved to the 95th–99th percentile
- 2026-10-25 Priority changed: MEDIUM → HIGH
- 2026-11-05 Affected versions changed · Red Hat
References
More BerriAI Litellm vulnerabilities
- TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
- TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
- TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
- TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
- TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
- TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-35029 · CVE Program
- CVE-2026-35029 · NVD
- FIRST EPSS
- GHSA-53mr-6c8q-9789 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-35029 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences