LiteLLM through 2026-04-08 allows remote attackers to execute arbitrary code via bytecode…
Priority HIGH 73CWE-420Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
LiteLLM through 2026-04-08 allows remote attackers to execute arbitrary code via bytecode rewriting at the /guardrails/test_custom_code URI.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.1702 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial litellm (PyPI): 1.83.10Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BerriAI | LiteLLM | bb0639701796218a3447160e55c0f1097446e4e6085df7dfd39f476d4143743f | — | No fix listed | CNA |
| — | litellm (PyPI) | 1.81.8 to before 1.83.10 | 1.83.10 | Patch available | GHSA-wxxx-gvqv-xp7p |
- LiteLLM VendorBerriAI Affected bb0639701796218a3447160e55c0f1097446e4e6085df7dfd39f476d4143743f Fixed in — No fix listed CNA
- litellm (PyPI) Vendor— Affected 1.81.8 to before 1.83.10 Fixed in 1.83.10 Patch available GHSA-wxxx-gvqv-xp7p
Remediation
- Fix · GHSA-wxxx-gvqv-xp7p litellm (PyPI) Fixed in 1.83.10 Advisory →
Red Hat 2 advisories
- RHSA-2026:30056 Released 2026-06-25 · Red Hat rating ImportantRHOAI 3.3.4 - Red Hat OpenShift AI
- Red Hat OpenShift AI 3.3 registry.redhat.io/rhoai/odh-llama-stack-core-rhel9
- RHSA-2026:24866 Released 2026-06-09 · Red Hat rating CriticalRed Hat Ansible Automation Platform 2.6 Container Release Update
- Red Hat Ansible Automation Platform 2.6 registry.redhat.io/ansible-automation-platform-26/controller-rhel9, registry.redhat.io/ansible-automation-platform-26/eda-controller-rhel9, registry.redhat.io/ansible-automation-platform-26/ee-supported-rhel9 +7
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Lightspeed Core | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2.6 | Fixed | RHSA-2026:24866 |
| Red Hat OpenShift AI 3.3 | Fixed | RHSA-2026:30056 |
Not affected: 3 products
- Red Hat Ansible Automation Platform 2.6
- Red Hat OpenShift AI (RHOAI)
- Red Hat OpenShift AI 3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40217
- 2026-10-03 Alias added: GHSA-wxxx-gvqv-xp7p
- 2026-10-25 EPSS moved to the 95th–99th percentile
- 2026-11-05 Affected versions changed · Red Hat
References
More BerriAI Litellm vulnerabilities
- TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
- TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
- TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
- TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
- TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
- TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-40217 · CVE Program
- CVE-2026-40217 · NVD
- FIRST EPSS
- GHSA-wxxx-gvqv-xp7p · GitHub Advisory Database · CC BY 4.0
- CVE-2026-40217 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences