Read the docs
TI-2026-29076 Aliases CVE-2026-40296GHSA-hrmw-qprp-wgmc

PhpSpreadsheet vulnerable to XSS in HTML writer via custom number format codes

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. The HTML writer skips htmlspecialchars escaping when a cell's formatted value differs from the original value. When a cell has a custom number format containing the text placeholder @ along with any additional literal characters (for example ". @", "@ ", or "x@"), the formatter replaces @ with the cell value and adds the extra characters, causing the formatted value to differ from the original and bypassing HTML escaping entirely. An attacker who can control the cell value and number format of an uploaded spreadsheet that is later converted to HTML and displayed to other users can achieve stored cross-site scripting. This issue is fixed in versions 5.7.0, 3.10.5, 2.4.5, 2.1.16, and 1.30.4.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00225 13th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpoffice/phpspreadsheet (Packagist): 5.7.0, 3.10.5, 2.4.5 +2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPOfficePhpSpreadsheet4.0.0 – 5.6.0; 3.3.0 – 3.10.4; 2.2.0 – 2.4.4; 2.0.0 – 2.1.15; up to 1.30.3—No fix listedCNA
—phpoffice/phpspreadsheet (Packagist)4.0.0 to before 5.7.05.7.0Patch availableGHSA-hrmw-qprp-wgmc
—phpoffice/phpspreadsheet (Packagist)3.3.0 to before 3.10.53.10.5Patch availableGHSA-hrmw-qprp-wgmc
—phpoffice/phpspreadsheet (Packagist)2.2.0 to before 2.4.52.4.5Patch availableGHSA-hrmw-qprp-wgmc
—phpoffice/phpspreadsheet (Packagist)2.0.0 to before 2.1.162.1.16Patch availableGHSA-hrmw-qprp-wgmc
—phpoffice/phpspreadsheet (Packagist)before 1.30.41.30.4Patch availableGHSA-hrmw-qprp-wgmc
  • PhpSpreadsheet VendorPHPOffice Affected 4.0.0 – 5.6.0; 3.3.0 – 3.10.4; 2.2.0 – 2.4.4; 2.0.0 – 2.1.15; up to 1.30.3 Fixed in — No fix listed CNA
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 4.0.0 to before 5.7.0 Fixed in 5.7.0 Patch available GHSA-hrmw-qprp-wgmc
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.3.0 to before 3.10.5 Fixed in 3.10.5 Patch available GHSA-hrmw-qprp-wgmc
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-hrmw-qprp-wgmc
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.16 Fixed in 2.1.16 Patch available GHSA-hrmw-qprp-wgmc
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.30.4 Fixed in 1.30.4 Patch available GHSA-hrmw-qprp-wgmc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*before 1.30.4; 2.0.0 to before 2.1.16; 2.2.0 to before 2.4.5; 3.3.0 to before 3.10.5; 4.0.0 to before 5.7.0VulnerablePHPOffice
  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.30.4; 2.0.0 to before 2.1.16; 2.2.0 to before 2.4.5; 3.3.0 to before 3.10.5; 4.0.0 to before 5.7.0 Vulnerable ·PHPOffice

Remediation

  • Fix · GHSA-hrmw-qprp-wgmc phpoffice/phpspreadsheet (Packagist) Fixed in 5.7.0 Advisory →
  • Fix · GHSA-hrmw-qprp-wgmc phpoffice/phpspreadsheet (Packagist) Fixed in 3.10.5 Advisory →
  • Fix · GHSA-hrmw-qprp-wgmc phpoffice/phpspreadsheet (Packagist) Fixed in 2.4.5 Advisory →
  • Fix · GHSA-hrmw-qprp-wgmc phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.16 Advisory →
  • Fix · GHSA-hrmw-qprp-wgmc phpoffice/phpspreadsheet (Packagist) Fixed in 1.30.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40296
  2. 2026-10-03 Alias added: GHSA-hrmw-qprp-wgmc

References

  • TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
  • TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
  • TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
  • TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
  • TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
  • TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
See all 24 →

Sources