Flowise: Authenticated RCE Via MCP Adapters
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, due to unsafe serialization of stdio commands in the MCP adapter, an authenticated attacker can add an MCP stdio server with an arbitrary command, achieving command execution. The vulnerability lies in a bug in the input sanitization from the “Custom MCP” configuration in http://localhost:3000/canvas - where any user can add a new MCP, when doing so - adding a new MCP using stdio, the user can add any command, even though your code have input sanitization checks such as validateCommandInjection and validateArgsForLocalFileAccess, and a list of predefined specific safe commands - these commands, for example "npx" can be combined with code execution arguments ("-c touch /tmp/pwn") that enable direct code execution on the underlying OS. This vulnerability is fixed in 3.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.0 | 3.1.0 | Patch available | CNA |
| FlowiseAI | flowise-components | before 3.1.0 | 3.1.0 | Patch available | CNA |
| — | flowise (npm) | before 3.1.0 | 3.1.0 | Patch available | GHSA-c9gw-hvqq-f33r |
| — | flowise-components (npm) | before 3.1.0 | 3.1.0 | Patch available | GHSA-c9gw-hvqq-f33r |
- Flowise VendorFlowiseAI Affected before 3.1.0 Fixed in 3.1.0 Patch available CNA
- flowise-components VendorFlowiseAI Affected before 3.1.0 Fixed in 3.1.0 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-c9gw-hvqq-f33r
- flowise-components (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-c9gw-hvqq-f33r
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.0
- Fix · CNA flowise-components (FlowiseAI) Fixed in 3.1.0
- Fix · GHSA-c9gw-hvqq-f33r flowise (npm) Fixed in 3.1.0 Advisory →
- Fix · GHSA-c9gw-hvqq-f33r flowise-components (npm) Fixed in 3.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40933
- 2026-10-03 Alias added: GHSA-c9gw-hvqq-f33r
- 2026-10-25 EPSS moved to the 95th–99th percentile
References
Advisory 2
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-40933 · CVE Program
- CVE-2026-40933 · NVD
- FIRST EPSS
- GHSA-c9gw-hvqq-f33r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences