Read the docs
TI-2026-29874 Aliases CVE-2026-41268GHSA-cvrr-qhgw-2mm6

Flowise: Flowise Parameter Override Bypass Remote Command Execution

Priority HIGH 76CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.1744 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.1.0flowise (npm): 3.1.0+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowisebefore 3.1.03.1.0Patch availableCNA
—flowise (npm)before 3.1.03.1.0Patch availableGHSA-cvrr-qhgw-2mm6
—flowise-components (npm)before 3.1.03.1.0Patch availableGHSA-cvrr-qhgw-2mm6
  • Flowise VendorFlowiseAI Affected before 3.1.0 Fixed in 3.1.0 Patch available CNA
  • flowise (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-cvrr-qhgw-2mm6
  • flowise-components (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-cvrr-qhgw-2mm6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*before 3.1.0VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions before 3.1.0 Vulnerable ·FlowiseAI

Remediation

  • Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.0
  • Fix · GHSA-cvrr-qhgw-2mm6 flowise (npm) Fixed in 3.1.0 Advisory →
  • Fix · GHSA-cvrr-qhgw-2mm6 flowise-components (npm) Fixed in 3.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41268
  2. 2026-10-03 Alias added: GHSA-cvrr-qhgw-2mm6
  3. 2026-10-25 EPSS moved to the 95th–99th percentile

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources