OpenAM LDAP Injection via `_queryId` Parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, IdentityResourceV1.queryCollection() passes the _queryId parameter from /json/{realm}/users to CrestQuery with escapeQueryId disabled, bypassing protection added for CVE-2021-29156. The unescaped value reaches DJLDAPv3Repo.getFilter(), where it is concatenated into an LDAP filter, allowing an authenticated attacker to inject LDAP metacharacters for user enumeration and blind LDAP injection. This issue is fixed in version 16.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenIdentityPlatform | OpenAM | before 16.1.1 | 16.1.1 | Patch available | CNA |
| — | org.openidentityplatform.openam:openam-core-rest (Maven) | before 16.1.1 | 16.1.1 | Patch available | GHSA-2vg8-q4c2-5cw3 |
- OpenAM VendorOpenIdentityPlatform Affected before 16.1.1 Fixed in 16.1.1 Patch available CNA
- org.openidentityplatform.openam:openam-core-rest (Maven) Vendor— Affected before 16.1.1 Fixed in 16.1.1 Patch available GHSA-2vg8-q4c2-5cw3
Remediation
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.1
- Fix · GHSA-2vg8-q4c2-5cw3 org.openidentityplatform.openam:openam-core-rest (Maven) Fixed in 16.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41573
- 2026-10-03 Alias added: GHSA-2vg8-q4c2-5cw3
- 2026-10-28 Weakness changed · GHSA-2vg8-q4c2-5cw3
- 2026-10-28 2 new references · GHSA-2vg8-q4c2-5cw3
References
Advisory 2
More OpenIdentityPlatform vulnerabilities
- TI-2025-20332 OpenDJ Denial of Service (Dos) using alias loop CVSS 4.0HIGH 8.7
- TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
- TI-2026-86693 Session token disclosure in OpenAM notification WebSocket CVSS 4.0CRITICAL 10.0
- TI-2026-86692 Authentication bypass in OpenAM SAML login accepts unsigned assertions CVSS 4.0CRITICAL 9.3
- TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypass CVSS 4.0CRITICAL 9.3
- TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of service CVSS 4.0HIGH 8.7
Sources
- CVE-2026-41573 · CVE Program
- CVE-2026-41573 · NVD
- FIRST EPSS
- GHSA-2vg8-q4c2-5cw3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences