n8n: Credential Authorization Bypass in dynamic-node-parameters Allows Foreign API Key Replay
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
n8n is an open source workflow automation platform. Prior to versions 1.123.33 and 2.17.5, the dynamic-node-parameters endpoints did not verify whether the authenticated caller was authorized to use a supplied credential reference. An authenticated user with access to a shared workflow could supply a foreign credential ID in the request body, causing the backend to decrypt and use that credential in a helper execution path where the caller also controls the destination URL. This allowed the caller to force the backend to authenticate against attacker-controlled infrastructure using a credential belonging to another user, effectively exfiltrating a reusable API key. The issue is not limited to any single node type; any node that resolves credentials dynamically through these endpoints may be affected. This issue has been patched in versions 1.123.33, 2.17.5, and 2.18.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.33; 2.17.0 to before 2.17.5 | 1.123.33, 2.17.5 | Patch available | CNA |
| — | n8n (npm) | 2.17.0 to before 2.17.5 | 2.17.5 | Patch available | GHSA-r4v6-9fqc-w5jr |
| — | n8n (npm) | before 1.123.33 | 1.123.33 | Patch available | GHSA-r4v6-9fqc-w5jr |
- n8n Vendorn8n Affected before 1.123.33; 2.17.0 to before 2.17.5 Fixed in 1.123.33, 2.17.5 Patch available CNA
- n8n (npm) Vendor— Affected 2.17.0 to before 2.17.5 Fixed in 2.17.5 Patch available GHSA-r4v6-9fqc-w5jr
- n8n (npm) Vendor— Affected before 1.123.33 Fixed in 1.123.33 Patch available GHSA-r4v6-9fqc-w5jr
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.33, 2.17.5
- Fix · GHSA-r4v6-9fqc-w5jr n8n (npm) Fixed in 2.17.5 Advisory →
- Fix · GHSA-r4v6-9fqc-w5jr n8n (npm) Fixed in 1.123.33 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42226
- 2026-10-03 Alias added: GHSA-r4v6-9fqc-w5jr
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-42226 · CVE Program
- CVE-2026-42226 · NVD
- FIRST EPSS
- GHSA-r4v6-9fqc-w5jr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences