n8n: Unauthenticated Denial of Service via MCP Client Registration
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, the MCP OAuth client registration endpoint accepted unauthenticated requests and stored client data without adequate resource controls. An unauthenticated remote attacker could exhaust server memory resources by sending large registration payloads, rendering the n8n instance unavailable. The MCP enable/disable toggle gates MCP access but did not restrict client registrations, meaning the endpoint is reachable regardless of whether MCP access is enabled on the instance. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.32; 2.17.0 to before 2.17.4; 2.18.0 to before 2.18.1 | 1.123.32, 2.17.4, 2.18.1 | Patch available | CNA |
| — | n8n (npm) | before 1.123.32 | 1.123.32 | Patch available | GHSA-49m9-pgww-9vq6 |
| — | n8n (npm) | 2.18.0 to before 2.18.1 | 2.18.1 | Patch available | GHSA-49m9-pgww-9vq6 |
| — | n8n (npm) | 2.0.0 to before 2.17.4 | 2.17.4 | Patch available | GHSA-49m9-pgww-9vq6 |
- n8n Vendorn8n Affected before 1.123.32; 2.17.0 to before 2.17.4; 2.18.0 to before 2.18.1 Fixed in 1.123.32, 2.17.4, 2.18.1 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.32 Fixed in 1.123.32 Patch available GHSA-49m9-pgww-9vq6
- n8n (npm) Vendor— Affected 2.18.0 to before 2.18.1 Fixed in 2.18.1 Patch available GHSA-49m9-pgww-9vq6
- n8n (npm) Vendor— Affected 2.0.0 to before 2.17.4 Fixed in 2.17.4 Patch available GHSA-49m9-pgww-9vq6
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.32, 2.17.4, 2.18.1
- Fix · GHSA-49m9-pgww-9vq6 n8n (npm) Fixed in 1.123.32 Advisory →
- Fix · GHSA-49m9-pgww-9vq6 n8n (npm) Fixed in 2.18.1 Advisory →
- Fix · GHSA-49m9-pgww-9vq6 n8n (npm) Fixed in 2.17.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-42236
- 2026-10-03 Alias added: GHSA-49m9-pgww-9vq6
- 2026-10-14 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-42236 · CVE Program
- CVE-2026-42236 · NVD
- FIRST EPSS
- GHSA-49m9-pgww-9vq6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences