electerm: RCE via malicious SSH server filename in openFileWithEditor
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.7.9, a code execution (RCE) vulnerability exists in electerm's SFTP open with system editor or "Edit with custom editor" feature. When a user opts to edit a file using open with system editor or open with a custom editor, the filename is passed directly into a command line without sanitization. A malicious actor controlling the SSH server or user OS can exploit this by crafting a filename containing shell metacharacters. If a victim subsequently attempts to edit this file, the injected commands are executed on their machine with the user's privileges. This could allow the attacker to run arbitrary code, install malware, or move laterally within the network. This issue has been patched in version 3.7.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| electerm | electerm | before 3.7.9 | 3.7.9 | Patch available | CNA |
| — | electerm (npm) | before 3.7.9 | 3.7.9 | Patch available | GHSA-q4p8-8j9m-8hxj |
- electerm Vendorelecterm Affected before 3.7.9 Fixed in 3.7.9 Patch available CNA
- electerm (npm) Vendor— Affected before 3.7.9 Fixed in 3.7.9 Patch available GHSA-q4p8-8j9m-8hxj
Remediation
- Fix · CNA electerm (electerm) Fixed in 3.7.9
- Fix · GHSA-q4p8-8j9m-8hxj electerm (npm) Fixed in 3.7.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-43943
- 2026-10-03 Alias added: GHSA-q4p8-8j9m-8hxj
References
Patch 2
More Electerm vulnerabilities
- TI-2020-14501 An issue was discovered in Electerm 1.3.22, allows attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2026-30086 electerm has Command Injection Vulnerability via runMac function CVSS 3.1CRITICAL 9.8
- TI-2026-30087 electerm has Command Injection Vulnerability via runLinux function CVSS 3.1CRITICAL 9.8
- TI-2026-31998 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click CVSS 3.1CRITICAL 9.6
- TI-2026-32001 electerm: dangerous code can be run through links or command line CVSS 4.0CRITICAL 9.4
- TI-2026-33147 electerm: Local code through electerm's single-instance socket CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-43943 · CVE Program
- CVE-2026-43943 · NVD
- FIRST EPSS
- GHSA-q4p8-8j9m-8hxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences