Read the docs
TI-2026-32147 Aliases CVE-2026-44167GHSA-3qpq-r242-jqj7

phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00201 10th percentileScored 2026-11-07
Fix Fixed phpseclib (phpseclib): 3.0.52, 2.0.54, 1.0.29phpseclib/phpseclib (Packagist): 1.0.29, 2.0.54, 3.0.52

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpseclibphpseclib3.0.0 to before 3.0.52; 2.0.0 to before 2.0.54; 0.1.1 to before 1.0.293.0.52, 2.0.54, 1.0.29Patch availableCNA
—phpseclib/phpseclib (Packagist)0.1.1 to before 1.0.291.0.29Patch availableGHSA-3qpq-r242-jqj7
—phpseclib/phpseclib (Packagist)2.0.0 to before 2.0.542.0.54Patch availableGHSA-3qpq-r242-jqj7
—phpseclib/phpseclib (Packagist)3.0.0 to before 3.0.523.0.52Patch availableGHSA-3qpq-r242-jqj7
  • phpseclib Vendorphpseclib Affected 3.0.0 to before 3.0.52; 2.0.0 to before 2.0.54; 0.1.1 to before 1.0.29 Fixed in 3.0.52, 2.0.54, 1.0.29 Patch available CNA
  • phpseclib/phpseclib (Packagist) Vendor— Affected 0.1.1 to before 1.0.29 Fixed in 1.0.29 Patch available GHSA-3qpq-r242-jqj7
  • phpseclib/phpseclib (Packagist) Vendor— Affected 2.0.0 to before 2.0.54 Fixed in 2.0.54 Patch available GHSA-3qpq-r242-jqj7
  • phpseclib/phpseclib (Packagist) Vendor— Affected 3.0.0 to before 3.0.52 Fixed in 3.0.52 Patch available GHSA-3qpq-r242-jqj7

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:*——phpseclib
  • cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:* Versions — — ·phpseclib

Remediation

  • Fix · CNA phpseclib (phpseclib) Fixed in 3.0.52, 2.0.54, 1.0.29
  • Fix · GHSA-3qpq-r242-jqj7 phpseclib/phpseclib (Packagist) Fixed in 1.0.29 Advisory →
  • Fix · GHSA-3qpq-r242-jqj7 phpseclib/phpseclib (Packagist) Fixed in 2.0.54 Advisory →
  • Fix · GHSA-3qpq-r242-jqj7 phpseclib/phpseclib (Packagist) Fixed in 3.0.52 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44167
  2. 2026-10-03 Alias added: GHSA-3qpq-r242-jqj7

References

  • TI-2026-40135 Server-side request forgery in phpseclib CVSS 3.1MEDIUM 5.8
  • TI-2026-57943 phpseclib — non-constant-time X25519 scalar multiplication permits full private-key recovery CVSS 3.1MEDIUM 6.3
  • TI-2026-29008 phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals() CVSS 3.1LOW 3.7
  • TI-2023-29213 In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in… CVSS 3.1HIGH 7.5
  • TI-2024-18192 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before… CVSS 3.1HIGH 7.5
  • TI-2024-18191 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before… CVSS 3.1HIGH 7.5
See all 10 →

Sources