Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 13.0.0 to before 15.5.16; 16.0.0 to before 16.2.5 | 15.5.16, 16.2.5 | Patch available | CNA |
| — | next (npm) | 13.0.0 to before 15.5.16 | 15.5.16 | Patch available | GHSA-gx5p-jg67-6x7h |
| — | next (npm) | 16.0.0 to before 16.2.5 | 16.2.5 | Patch available | GHSA-gx5p-jg67-6x7h |
- next.js Vendorvercel Affected 13.0.0 to before 15.5.16; 16.0.0 to before 16.2.5 Fixed in 15.5.16, 16.2.5 Patch available CNA
- next (npm) Vendor— Affected 13.0.0 to before 15.5.16 Fixed in 15.5.16 Patch available GHSA-gx5p-jg67-6x7h
- next (npm) Vendor— Affected 16.0.0 to before 16.2.5 Fixed in 16.2.5 Patch available GHSA-gx5p-jg67-6x7h
Remediation
- Fix · CNA next.js (vercel) Fixed in 15.5.16, 16.2.5
- Fix · GHSA-gx5p-jg67-6x7h next (npm) Fixed in 15.5.16 Advisory →
- Fix · GHSA-gx5p-jg67-6x7h next (npm) Fixed in 16.2.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat Trusted Artifact Signer | Affected | No fix yet: Fix deferred |
| streams for Apache Kafka 3 | Affected | No fix yet: Fix deferred |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Hardened Images
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44580
- 2026-10-03 Alias added: GHSA-gx5p-jg67-6x7h
References
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2026-44580 · CVE Program
- CVE-2026-44580 · NVD
- FIRST EPSS
- GHSA-gx5p-jg67-6x7h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-44580 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences