WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
WordPress Coding Standards is a set of PHP_CodeSniffer rules (sniffs) that enforce WordPress coding conventions. From 0.14.1 until 3.4.1, the WordPress.WP.EnqueuedResourceParameters sniff (active in the WordPress and WordPress-Extra rulesets) reconstructed the $ver argument passed to functions such as wp_enqueue_script() and ran it through eval() inside its is_falsy() method, so a maliciously crafted argument such as 'system'('id') would execute during a scan; as a result, running PHPCS with WordPressCS over untrusted PHP (for example a CI pipeline that lints pull requests, or a developer reviewing third-party code) could lead to arbitrary command execution on the scanning host. The WordPress-Core and WordPress-Docs rulesets are not affected. This issue is fixed in version 3.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress-Coding-Standards | 0.14.1 to before 3.4.1 | 3.4.1 | Patch available | CNA |
| — | wp-coding-standards/wpcs (Packagist) | 0.14.1 to before 3.4.1 | 3.4.1 | Patch available | GHSA-3pwp-g2mj-5p3v |
- WordPress-Coding-Standards VendorWordPress Affected 0.14.1 to before 3.4.1 Fixed in 3.4.1 Patch available CNA
- wp-coding-standards/wpcs (Packagist) Vendor— Affected 0.14.1 to before 3.4.1 Fixed in 3.4.1 Patch available GHSA-3pwp-g2mj-5p3v
Remediation
- Fix · CNA WordPress-Coding-Standards (WordPress) Fixed in 3.4.1
- Fix · GHSA-3pwp-g2mj-5p3v wp-coding-standards/wpcs (Packagist) Fixed in 3.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45293
- 2026-10-03 Alias added: GHSA-3pwp-g2mj-5p3v
References
Other 5
- https://github.com/WordPress/WordPress-Coding-Standards/security/advisories/GHSA-3pwp-g2mj-5p3v
- https://github.com/WordPress/WordPress-Coding-Standards/pull/2771
- https://github.com/WordPress/WordPress-Coding-Standards/commit/a29048d0bbef5cf25d42349c74e4072d3cbc8325
- https://github.com/WordPress/WordPress-Coding-Standards/releases/tag/3.4.1
- https://github.com/WordPress/WordPress-Coding-Standards
More WordPress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15454 The File Manager (wp-file-manager) plugin before 6.9 for WordPress allows remote… KEVCVSS 3.1CRITICAL 10.0
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2020-09427 The Snap Creek Duplicator plugin before 1.3.28 for WordPress (and Duplicator Pro before… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2026-45293 · CVE Program
- CVE-2026-45293 · NVD
- FIRST EPSS
- GHSA-3pwp-g2mj-5p3v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences