An unauthenticated attacker can make `get_page_template()` page-template resolution…
Priority CRITICAL 94Exploited in the wildCWE-98Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-98.
Summary
An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the active theme directories. If relevant pre-conditions for both the server and the active theme are met, this can lead to RCE.
Why it matters now
Exploitation Active In CISA KEV since 2026-09-25CISA due date 2026-09-28
EPSS 0.95769 99th percentileScored 2026-11-07
Fix Fixed WordPress (WordPress): 7.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | before 7.1.2 | 7.1.2 | Patch available | CNA |
- WordPress VendorWordPress Affected before 7.1.2 Fixed in 7.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | before 4.7.37; 4.8 to before 4.8.32; 4.9 to before 4.9.33; 5.0 to before 5.0.29; 5.1 to before 5.1.26; 5.2 to before 5.2.28; 5.3 to before 5.3.25; 5.4 to before 5.4.23; 5.5 to before 5.5.22; 5.6 to before 5.6.21; 5.7 to before 5.7.19; 5.8 to before 5.8.17; 5.9 to before 5.9.18; 6.0 to before 6.0.16; 6.1 to before 6.1.14; 6.2 to before 6.2.13; 6.3 to before 6.3.12; 6.4 to before 6.4.12; 6.5 to before 6.5.12; 6.6 to before 6.6.9; 6.7 to before 6.7.9; 6.8 to before 6.8.10; 6.9 to before 6.9.9; 7.0 to before 7.0.6; 7.1 to before 7.1.2 | Vulnerable | WordPress |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions before 4.7.37; 4.8 to before 4.8.32; 4.9 to before 4.9.33; 5.0 to before 5.0.29; 5.1 to before 5.1.26; 5.2 to before 5.2.28; 5.3 to before 5.3.25; 5.4 to before 5.4.23; 5.5 to before 5.5.22; 5.6 to before 5.6.21; 5.7 to before 5.7.19; 5.8 to before 5.8.17; 5.9 to before 5.9.18; 6.0 to before 6.0.16; 6.1 to before 6.1.14; 6.2 to before 6.2.13; 6.3 to before 6.3.12; 6.4 to before 6.4.12; 6.5 to before 6.5.12; 6.6 to before 6.6.9; 6.7 to before 6.7.9; 6.8 to before 6.8.10; 6.9 to before 6.9.9; 7.0 to before 7.0.6; 7.1 to before 7.1.2 Vulnerable ·WordPress
Remediation
- Fix · CNA WordPress (WordPress) Fixed in 7.1.2
Vendor assessments
Timeline
- 2026-09-25 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2026-87902
- 2026-10-25 EPSS moved to the 99th percentile and above
References
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
- TI-2022-06039 SQL injection in WordPress CVSS 3.1HIGH 8.0
Sources
- CVE-2026-87902 · CVE Program
- CVE-2026-87902 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- CVE-2026-87902 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences